summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnustep-apps/cdplayer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnustep-apps/cdplayer')
-rw-r--r--gnustep-apps/cdplayer/Manifest1
-rw-r--r--gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild36
-rw-r--r--gnustep-apps/cdplayer/metadata.xml9
3 files changed, 46 insertions, 0 deletions
diff --git a/gnustep-apps/cdplayer/Manifest b/gnustep-apps/cdplayer/Manifest
new file mode 100644
index 000000000000..888e5d4c69eb
--- /dev/null
+++ b/gnustep-apps/cdplayer/Manifest
@@ -0,0 +1 @@
+DIST cdplayer-0.6.0.tar.gz 365695 SHA256 a8f7f357abe629b987cb96ef61448fa21a252c82e748927569c9a98332d19889 SHA512 a777a8eb3b924fca7905b8063d9cbc64f1b3b5efd8f6ebcb4366c69e5c085d14cc416a25d6b389025d7ac2f80ee08e2adc742aa96c2c9f70170af22c807b7809 WHIRLPOOL ebb5d513aeb8358be62f4f88cb42892f399e2d359f9420033a51d38cc7e42e58d91b2ef2221ed95c36f14f58e13636e988ffbf6670ff9ab64f868a1185d46365
diff --git a/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild b/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild
new file mode 100644
index 000000000000..acb424740539
--- /dev/null
+++ b/gnustep-apps/cdplayer/cdplayer-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnustep-2
+
+DESCRIPTION="Small CD Audio Player for GNUstep"
+HOMEPAGE="https://github.com/schik/cdplayer"
+SRC_URI="https://github.com/schik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="dbus"
+DEPEND="dev-libs/libcdio
+ dev-libs/libcdio-paranoia
+ gnustep-apps/cynthiune
+ dbus? ( gnustep-libs/dbuskit )"
+RDEPEND="${DEPEND}
+ !gnustep-libs/cddb"
+
+src_prepare() {
+ sed -e "s#cdda.h#paranoia/cdda.h#" \
+ -e "s#paranoia.h#paranoia/paranoia.h#" \
+ -i AudioCD/AudioCD.h || die "AudioCD.h sed failed"
+}
+
+src_compile() {
+ local myconf=""
+ use dbus || myconf="${myconf} notifications=no"
+
+ egnustep_env
+ egnustep_make ${myconf}
+}
diff --git a/gnustep-apps/cdplayer/metadata.xml b/gnustep-apps/cdplayer/metadata.xml
new file mode 100644
index 000000000000..9517eb0b7dd2
--- /dev/null
+++ b/gnustep-apps/cdplayer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnustep</herd>
+ <longdescription>Small CD Audio Player for GNUstep</longdescription>
+ <upstream>
+ <remote-id type="github">schik/cdplayer</remote-id>
+ </upstream>
+</pkgmetadata>