summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-03 14:34:21 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-03 14:34:51 +0100
commit3ba026c81505f7691275d07bbf190572296f9412 (patch)
treee525f4c5197b817efbb91080493db5792e9b00e6 /gnome-extra
parentapp-shells/bash-completion: Deselect a failing test (diff)
downloadgentoo-3ba026c81505f7691275d07bbf190572296f9412.tar.gz
gentoo-3ba026c81505f7691275d07bbf190572296f9412.tar.bz2
gentoo-3ba026c81505f7691275d07bbf190572296f9412.zip
gnome-extra/gnome-shell-extension-appindicator: add 49
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-49.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index c933e369a8d8..954c661fb60b 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-extension-appindicator-46.tar.gz 60986 BLAKE2B 3d058aed56c9ba3c931fe50ca2b5cf48f89b32765afbc5adf6c8004f6c68eee874988801a6358ce574a0d3e7f563c81899632e217b8a00a5e1b4ce62e1f31387 SHA512 0616503a9e5a471bbe64b2f2d9fb853ba1d67e902d9b72b464647f70e8e6392ab9135955c87c99e83d96941cb29505f03cab5ad257ffc5a80e77221d4fcd9730
DIST gnome-shell-extension-appindicator-47.tar.gz 63339 BLAKE2B c5efc80cdaa1b092ad242ae6535042ad695933383d69769501882b70563e9fa1fa58c44262a1e157f8a501b276fe7b2da91c0636bdaf0a35b836959aa89903b9 SHA512 939c0340586141f0f8d6f7722d9d084bef35d598f19c8ac2fbdba3c8174b91a823248ddd56d6361b16ed8404b53633899206d7434d4e9479544589b22e269933
DIST gnome-shell-extension-appindicator-48.tar.gz 64682 BLAKE2B daaf9ece32e121352602ccee8e99f901246a2ddf4186a96372fa1f15f422f95e6a1328d40e800daaea069aff955f33de8482c05bc073026313ea33926a3b9e26 SHA512 04010d8bfcbb97b54dfa2e529ae1f3f38ecb8a70383b06dc39a0360767505742bc402cc49c9383d52a063c372820e1f02de15ed000715ff7fe6978bf01e1b0d9
+DIST gnome-shell-extension-appindicator-49.tar.gz 65665 BLAKE2B d1e0d151b42a7dc5631927415c05614fa4062b5061278c6d0ca770cf20166f3b88964e514e00fb2aec80ddf4f6dd8fe83fe136e19618d44b1e77a333be8c5144 SHA512 2fed5b3f7042df836cc3ceb1ce303f41de29f56c58570acb5e7150ab4f019e9441e0a91eb71afd5757b465a81a44638eafd2aa5944ff46a71f20095f488ab945
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-49.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-49.ebuild
new file mode 100644
index 000000000000..6d843831ebf9
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-49.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}