summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-18 18:28:51 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-18 17:56:40 -0400
commitae39e9d24a6d6e0044aed73b7a60e01f5eb3d9c0 (patch)
treedbe7ef12ddf4963ea02b810ba372b099c3ae7e35 /gnome-extra/sushi
parentapp-text/evince: Version bump to 45.0 (diff)
downloadgentoo-ae39e9d24a6d6e0044aed73b7a60e01f5eb3d9c0.tar.gz
gentoo-ae39e9d24a6d6e0044aed73b7a60e01f5eb3d9c0.tar.bz2
gentoo-ae39e9d24a6d6e0044aed73b7a60e01f5eb3d9c0.zip
gnome-extra/sushi: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32912 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-45.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index bb698a1e46bd..7cf17d1a5f33 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,2 +1,3 @@
DIST sushi-44.2.tar.xz 82236 BLAKE2B 144b2a068c0ed81e49236ed2f43125ec9df8eb853dac6d49e55c56d489f6dd41e1704b3e22996bd80bcbda07f0843a831bdbd8296606a9688376bf7fc6140406 SHA512 0e2cd6e619872e7ebd29b01bf6038b3db7f8202f20a77034451e69b722e46ee9f8e20378253f49ccb12b6060490c25555581f10823c778c42ab9edf41016a1da
+DIST sushi-45.0.tar.xz 83404 BLAKE2B 15a6e2c3b6a50451bfe72a17efaa14a934b040a415a198502b5d39a26aa039f1ec521ad71a98f319e98b023133834fc2eba42be77f9f86dd942e96a3eb8c47b6 SHA512 25f8183e8a98ece5f8fe8b62bd60c1570e580634bc154650c044d37a18f3848fac724a2bebcc59a6d2b55290cf2ec852abda21864b15d97b3395183c2391ae0f
DIST sushi-45.alpha.2.tar.xz 83288 BLAKE2B 587043020f59c1d1747393f8ad139e68764b1e98b89ad926f910f19b95504c166ec6fa340ee5a881c8643edd2c697c75843d3260cd9ac54c6cddd6e421862d02 SHA512 a5a658860731f64c00657fc34f1b494f656fb0981c10e8baf31641bbc84f6902a37853f13aab622abd40ad154a9f8e1e99e162c887e34f20f781ee33a70996ed
diff --git a/gnome-extra/sushi/sushi-45.0.ebuild b/gnome-extra/sushi/sushi-45.0.ebuild
new file mode 100644
index 000000000000..8c11aac1b315
--- /dev/null
+++ b/gnome-extra/sushi/sushi-45.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson optfeature xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ net-libs/webkit-gtk:4.1[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland)
+ $(meson_feature X X11)
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Support viewing file formats such as generated by LibreOffice" \
+ app-office/libreoffice app-office/libreoffice-bin
+}