summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-11-03 10:23:32 -0300
committerMart Raudsepp <leio@gentoo.org>2023-11-04 22:20:09 +0200
commit428146b69d4c4eca4cdd60f784cb66c110715a80 (patch)
tree170f19ccb10783ce9d3611e6ebcf053ec7746cc1 /gnome-extra/libgsf
parentmedia-video/qmplay2: Stabilize 23.10.22 amd64, #916859 (diff)
downloadgentoo-428146b69d4c4eca4cdd60f784cb66c110715a80.tar.gz
gentoo-428146b69d4c4eca4cdd60f784cb66c110715a80.tar.bz2
gentoo-428146b69d4c4eca4cdd60f784cb66c110715a80.zip
gnome-extra/libgsf: Version bump to 1.14.51
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33664 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.51.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index 983a67cf5de5..0f148c9baafe 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.50.tar.xz 702424 BLAKE2B dc6e3fa313cc99981cf521b4613ef135ea6836554be0cc557e49d77bd3259e1bf2150af1b7a41071f4b865c28a9b6153b6ef6e89d4868e4203ce7dc7da433c71 SHA512 e4a405d01440654bfe5059536524d494e5b66859235648bcf6031a74b59967504b50750f471bbe1607c4a5ef11cac98aa2ca9ebb31151cf5a19ffa340d421adb
+DIST libgsf-1.14.51.tar.xz 707488 BLAKE2B 08012d4df8e9256579069518a54198b9aa8c21c3d0c4297eb4ff829af666287cc186d846eecb277609ffe5a89d02a36344cedc67f6ed00354d018a692a99f4fe SHA512 b7c02e10762c93909a1aacb86f30b266ed8b0eeefe73ede5acb8ac0c1094a1e4be2b7bd3a59ebfc03180f8f72f2cc602e80c871a1b8a28f3fccfdd403ad24da7
diff --git a/gnome-extra/libgsf/libgsf-1.14.51.ebuild b/gnome-extra/libgsf/libgsf-1.14.51.ebuild
new file mode 100644
index 000000000000..1270ca3c4e5b
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.51.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GNOME2_EAUTORECONF=yes
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libgsf"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+IUSE="bzip2 gtk +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ test? ( dev-perl/XML-Parser )
+"
+
+PATCHES=(
+ "${FILESDIR}"/1.14.49-skip-valgrind-tests.patch
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}