summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-29 22:47:35 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-29 22:48:36 -0700
commitd0b0ecc2e7502eaa7fb8b7356cb5ec29062abed7 (patch)
tree8beda4a8b264a3cbc1b03fe9243b2841a1397976 /gnome-extra/gnome-logs/gnome-logs-42.0.ebuild
parentdev-libs/nss: drop 3.75-r1, 3.76-r1 (security cleanup p1) (diff)
downloadgentoo-d0b0ecc2e7502eaa7fb8b7356cb5ec29062abed7.tar.gz
gentoo-d0b0ecc2e7502eaa7fb8b7356cb5ec29062abed7.tar.bz2
gentoo-d0b0ecc2e7502eaa7fb8b7356cb5ec29062abed7.zip
gnome-extra/gnome-logs: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-logs/gnome-logs-42.0.ebuild')
-rw-r--r--gnome-extra/gnome-logs/gnome-logs-42.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnome-extra/gnome-logs/gnome-logs-42.0.ebuild b/gnome-extra/gnome-logs/gnome-logs-42.0.ebuild
new file mode 100644
index 000000000000..a77cf4b94132
--- /dev/null
+++ b/gnome-extra/gnome-logs/gnome-logs-42.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Log viewer for the systemd journal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Logs"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ gnome-base/gsettings-desktop-schemas
+ >=dev-libs/glib-2.43.90:2
+ >=x11-libs/gtk+-3.22:3
+ >=gui-libs/libhandy-1.5.0:1
+ sys-apps/systemd:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ app-text/docbook-xml-dtd:4.3
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ meson_src_configure -Dman=true
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}