summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-31 22:28:48 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-10-31 22:29:28 +0000
commit601e261fefe2a143f09db67637e1527074a9a802 (patch)
tree42dffadcda1eddd4575e79d8685d69d9e9014517 /games-util/mcrcon/mcrcon-0.7.2.ebuild
parentapp-portage/tatt: add 0.9 (diff)
downloadgentoo-601e261fefe2a143f09db67637e1527074a9a802.tar.gz
gentoo-601e261fefe2a143f09db67637e1527074a9a802.tar.bz2
gentoo-601e261fefe2a143f09db67637e1527074a9a802.zip
games-util/mcrcon: Version bump to 0.7.2, EAPI 8
For reals, this time! Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/mcrcon/mcrcon-0.7.2.ebuild')
-rw-r--r--games-util/mcrcon/mcrcon-0.7.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.7.2.ebuild b/games-util/mcrcon/mcrcon-0.7.2.ebuild
new file mode 100644
index 000000000000..80b64e933516
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://github.com/Tiiffi/mcrcon"
+SRC_URI="https://github.com/Tiiffi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS} -std=gnu99 -Wall -Wextra -Wpedantic"
+}
+
+src_install() {
+ emake install PREFIX="${ED}/usr"
+}