summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-07 19:56:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-07 19:56:36 +0100
commitf80a745a69eaad680c12650913c2c2939b8aaa50 (patch)
tree6c05096b590a8d9e75d24a52cbe95dfb0c425d82 /games-util/grfcodec
parentdev-util/gi-docgen: keyworded 2021.5 for hppa, bug #787269 (diff)
downloadgentoo-f80a745a69eaad680c12650913c2c2939b8aaa50.tar.gz
gentoo-f80a745a69eaad680c12650913c2c2939b8aaa50.tar.bz2
gentoo-f80a745a69eaad680c12650913c2c2939b8aaa50.zip
games-util/grfcodec: don't rely on git presence
Reported-by: Lars Wendler (Polynomial-C) Closes: https://bugs.gentoo.org/788724 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-util/grfcodec')
-rw-r--r--games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild b/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
index d4fd24bff446..29b89e829a39 100644
--- a/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
+++ b/games-util/grfcodec/grfcodec-6.0.6_p20210310.ebuild
@@ -25,6 +25,18 @@ DEPEND="
S="${WORKDIR}/grfcodec-${COMMIT}"
+src_configure() {
+ local mycmakeargs=(
+ # Make sure we don't use git by accident.
+ # Build system does not care much if it's
+ # executed successfully and populates
+ # YEARS / VERSION with empty values.
+ -DGIT_EXECUTABLE=/bin/do-not-use-git-executable
+ )
+
+ cmake_src_configure
+}
+
src_install() {
dobin "${BUILD_DIR}"/{grfcodec,grfid,grfstrip,nforenum}
doman docs/*.1