summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 15:36:51 +0000
committerSam James <sam@gentoo.org>2021-04-12 15:48:34 +0000
commit683c7dcfb4c3cb41e756bed668b5c41baab85522 (patch)
tree17ba02a50f06c15a054a72b0e9e5175d28d9cc89 /games-strategy
parentnet-libs/libesmtp: add 1.0.6_p20200824 (diff)
downloadgentoo-683c7dcfb4c3cb41e756bed668b5c41baab85522.tar.gz
gentoo-683c7dcfb4c3cb41e756bed668b5c41baab85522.tar.bz2
gentoo-683c7dcfb4c3cb41e756bed668b5c41baab85522.zip
games-strategy/xbattleai: update EAPI 6 -> 7, fix build, respect CC
Previous configure results were cached, causing misdetection of nsl. This also added to problems with respecting CC. Closes: https://bugs.gentoo.org/730850 Closes: https://bugs.gentoo.org/650044 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
index 34735392b6cb..f76d66031ae2 100644
--- a/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
+++ b/games-strategy/xbattleai/xbattleai-1.2.2-r2.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="A multi-player game of strategy and coordination"
HOMEPAGE="https://inf.ug.edu.pl/~piotao/xbattle/mirror/www.lysator.liu.se/XBattleAI/"
@@ -18,11 +20,18 @@ RDEPEND="
dev-lang/tk:0
x11-libs/libX11
x11-libs/libXext
- !games-strategy/xbattle"
-DEPEND="${RDEPEND}
+ !games-strategy/xbattle
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
app-text/rman
x11-misc/imake
- x11-base/xorg-proto"
+"
+
+DOCS=( CONTRIBUTORS README README.AI TODO xbattle.dot )
PATCHES=(
"${FILESDIR}"/${P}-sandbox.patch
@@ -31,10 +40,12 @@ PATCHES=(
src_prepare() {
default
rm -f xbcs/foo.xbc~ || die
+ rm config.cache || die
+
+ tc-export CC
}
src_install() {
- DOCS="CONTRIBUTORS README README.AI TODO xbattle.dot" \
- default
- mv "${D}/usr/bin/"{,xb_}gauntletCampaign || die
+ default
+ mv "${ED}/usr/bin/"{,xb_}gauntletCampaign || die
}