summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-27 04:46:15 +0000
committerSam James <sam@gentoo.org>2023-01-27 05:23:33 +0000
commit3075f396dfd814a3a8b4d2fdba9dd3d88dab1176 (patch)
tree557a4117f09126ae1d517f2b0d165867173abee8 /games-strategy/widelands
parentgames-action/supertuxkart: add 1.4 (diff)
downloadgentoo-3075f396dfd814a3a8b4d2fdba9dd3d88dab1176.tar.gz
gentoo-3075f396dfd814a3a8b4d2fdba9dd3d88dab1176.tar.bz2
gentoo-3075f396dfd814a3a8b4d2fdba9dd3d88dab1176.zip
games-strategy/widelands: fix build w/ gcc 13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy/widelands')
-rw-r--r--games-strategy/widelands/files/widelands-1.1-gcc-13.patch124
-rw-r--r--games-strategy/widelands/widelands-1.1.ebuild4
2 files changed, 128 insertions, 0 deletions
diff --git a/games-strategy/widelands/files/widelands-1.1-gcc-13.patch b/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
new file mode 100644
index 000000000000..c2f2501dff0d
--- /dev/null
+++ b/games-strategy/widelands/files/widelands-1.1-gcc-13.patch
@@ -0,0 +1,124 @@
+https://github.com/widelands/widelands/pull/5765
+
+From 14b9c357073126d11d719fd1a539bb7ef0154791 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Wed, 25 Jan 2023 23:42:42 +0100
+Subject: [PATCH] Fix build with gcc 13 by including <cstdint>
+
+Like other versions before, gcc 13 moved some includes around and as a
+result <cstdint> is no longer transitively included. Explicitly include
+it for uint16_t.
+--- a/src/base/md5.h
++++ b/src/base/md5.h
+@@ -21,6 +21,7 @@
+ #define WL_BASE_MD5_H
+
+ #include <cassert>
++#include <cstdint>
+ #include <cstring>
+ #include <string>
+
+--- a/src/base/random.h
++++ b/src/base/random.h
+@@ -20,6 +20,7 @@
+ #define WL_BASE_RANDOM_H
+
+ #include <cassert>
++#include <cstdint>
+ #include <string>
+
+ extern const uint32_t rng_sbox[256];
+--- a/src/base/time_string.h
++++ b/src/base/time_string.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_BASE_TIME_STRING_H
+ #define WL_BASE_TIME_STRING_H
+
++#include <cstdint>
+ #include <string>
+
+ /// Get a string representation conforming to ISO 8601 of the current time (in
+--- a/src/build_info.h
++++ b/src/build_info.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_BUILD_INFO_H
+ #define WL_BUILD_INFO_H
+
++#include <cstdint>
+ #include <string>
+
+ constexpr uint16_t kWidelandsCopyrightStart = 2002;
+--- a/src/graphic/align.h
++++ b/src/graphic/align.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_GRAPHIC_ALIGN_H
+ #define WL_GRAPHIC_ALIGN_H
+
++#include <cstdint>
+ #include <string>
+
+ #include "base/rect.h"
+--- a/src/graphic/text/textstream.h
++++ b/src/graphic/text/textstream.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_GRAPHIC_TEXT_TEXTSTREAM_H
+ #define WL_GRAPHIC_TEXT_TEXTSTREAM_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace RT {
+--- a/src/logic/generic_save_handler.h
++++ b/src/logic/generic_save_handler.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_LOGIC_GENERIC_SAVE_HANDLER_H
+ #define WL_LOGIC_GENERIC_SAVE_HANDLER_H
+
++#include <cstdint>
+ #include <functional>
+
+ #include "io/filesystem/filesystem.h"
+--- a/src/logic/map_revision.h
++++ b/src/logic/map_revision.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_LOGIC_MAP_REVISION_H
+ #define WL_LOGIC_MAP_REVISION_H
+
++#include <cstdint>
+ #include <string>
+
+ namespace Widelands {
+--- a/src/logic/save_handler.h
++++ b/src/logic/save_handler.h
+@@ -19,6 +19,8 @@
+ #ifndef WL_LOGIC_SAVE_HANDLER_H
+ #define WL_LOGIC_SAVE_HANDLER_H
+
++#include <cstdint>
++
+ #include "io/filesystem/filesystem.h"
+
+ namespace Widelands {
+--- a/src/map_io/map_elemental_packet.h
++++ b/src/map_io/map_elemental_packet.h
+@@ -19,6 +19,7 @@
+ #ifndef WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
+ #define WL_MAP_IO_MAP_ELEMENTAL_PACKET_H
+
++#include <cstdint>
+ #include <string>
+ #include <vector>
+
+--- a/src/scripting/persistence.h
++++ b/src/scripting/persistence.h
+@@ -19,6 +19,8 @@
+ #ifndef WL_SCRIPTING_PERSISTENCE_H
+ #define WL_SCRIPTING_PERSISTENCE_H
+
++#include <cstdint>
++
+ #include "scripting/lua.h"
+
+ class FileRead;
+--
+2.39.1
diff --git a/games-strategy/widelands/widelands-1.1.ebuild b/games-strategy/widelands/widelands-1.1.ebuild
index 694f1e6b01d3..4d2e256576f8 100644
--- a/games-strategy/widelands/widelands-1.1.ebuild
+++ b/games-strategy/widelands/widelands-1.1.ebuild
@@ -40,6 +40,10 @@ BDEPEND="
${PYTHON_DEPS}
sys-devel/gettext"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-gcc-13.patch
+)
+
src_configure() {
CMAKE_BUILD_TYPE=Release # disables -Werror