summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-simulation/micropolis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-simulation/micropolis')
-rw-r--r--games-simulation/micropolis/Manifest2
-rw-r--r--games-simulation/micropolis/metadata.xml6
-rw-r--r--games-simulation/micropolis/micropolis-1.0.ebuild56
3 files changed, 64 insertions, 0 deletions
diff --git a/games-simulation/micropolis/Manifest b/games-simulation/micropolis/Manifest
new file mode 100644
index 000000000000..b8c9da534f59
--- /dev/null
+++ b/games-simulation/micropolis/Manifest
@@ -0,0 +1,2 @@
+DIST micropolis-activity-source.tgz 7676438 SHA256 1b3c72dc3680a34b5fc5a740a6fb5cfc0b8775514da8ab7bb3b2965b20d4f8bc SHA512 fe65966c43d044e01a63a3cfe3cad48466eb1e5ec8b13c03abb52d582395a8ab527332d4d04454a4f32e85b65e55d72fe5e4d53a3f37b422d90e9208f00d9976 WHIRLPOOL 2bc497ce79b9041a6e3a2dcd84b4e135c844652afe23d546ad7aa5c66dee3422151329a04bbbc105a199427b4ed0580f79d3232d0b13f09a89b013e006321f3e
+DIST micropolis_git.patch 83549 SHA256 13419a4394242cd11d5cabd8b1b50787282ea16b55fdcfbeadf8505af46b0592 SHA512 9d1801478a27184c48d327094cad8238f7972c2cf3624c7c196375f2dd20c3374575b393d44cb2fb99613e19d66c4cc4fb27ae52df9fddf4e42adb42523bdc17 WHIRLPOOL fde6ad3bf7395ef51f482aba816d99bb5af302f357e4d9cd218d9ba7e4a0d78f8927e33c76cf0e340c5ff3b9b5b16f5e26495b07b5d80f701f560a1a7c7730ad
diff --git a/games-simulation/micropolis/metadata.xml b/games-simulation/micropolis/metadata.xml
new file mode 100644
index 000000000000..dbefa85e7356
--- /dev/null
+++ b/games-simulation/micropolis/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer><email>hanno@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/games-simulation/micropolis/micropolis-1.0.ebuild b/games-simulation/micropolis/micropolis-1.0.ebuild
new file mode 100644
index 000000000000..c2a4457352c8
--- /dev/null
+++ b/games-simulation/micropolis/micropolis-1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Free version of the well-known city building simulation"
+HOMEPAGE="http://www.donhopkins.com/home/micropolis/"
+SRC_URI="http://www.donhopkins.com/home/micropolis/${PN}-activity-source.tgz
+ http://rmdir.de/~michael/${PN}_git.patch"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+S=${WORKDIR}/${PN}-activity/
+
+src_unpack() {
+ unpack ${PN}-activity-source.tgz
+}
+
+src_prepare() {
+ epatch "${DISTDIR}"/${PN}_git.patch
+ sed -i -e "s:-O3:${CFLAGS}:" \
+ src/tclx/config.mk src/{sim,tcl,tk}/makefile || die
+ sed -i -e "s:XLDFLAGS=:&${LDFLAGS}:" \
+ src/tclx/config.mk || die
+}
+
+src_compile() {
+ emake -C src LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+
+ exeinto "${dir}/res"
+ doexe src/sim/sim
+ insinto "${dir}"
+ doins -r activity cities images manual res
+
+ games_make_wrapper micropolis res/sim "${dir}"
+ doicon Micropolis.png
+ make_desktop_entry micropolis "Micropolis" Micropolis
+
+ prepgamesdirs
+}