summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/coe2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/coe2')
-rw-r--r--games-rpg/coe2/Manifest1
-rw-r--r--games-rpg/coe2/coe2-2007-r1.ebuild56
-rw-r--r--games-rpg/coe2/metadata.xml20
3 files changed, 77 insertions, 0 deletions
diff --git a/games-rpg/coe2/Manifest b/games-rpg/coe2/Manifest
new file mode 100644
index 000000000000..2b2a32886de0
--- /dev/null
+++ b/games-rpg/coe2/Manifest
@@ -0,0 +1 @@
+DIST coe2_2007.zip 4937222 SHA256 7b7c281454f3c83ba510d4223ccfb6af77fd760fcb507d7e71cf633cd86aa3bb SHA512 db0d4ee2016ef3cf7159c227c494346fa0a0e9f9b20a6b520b67899570e3135a4286d6ada2f85d7ea7b55a1baeada41654d4fab29f5996357608f0d2d654b2ed WHIRLPOOL a9c1d989dc48dc43d5c2125f4420de9bdfe23dca9758d0f8eeac5bc19eef4aab124075530bbf04da1fc80f022718564e21d4a464b49306d3d104a733c50e7259
diff --git a/games-rpg/coe2/coe2-2007-r1.ebuild b/games-rpg/coe2/coe2-2007-r1.ebuild
new file mode 100644
index 000000000000..8d8aefe83bcc
--- /dev/null
+++ b/games-rpg/coe2/coe2-2007-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="Precursor to the Dominions series"
+HOMEPAGE="http://www.shrapnelgames.com/Illwinter/CoE2/"
+SRC_URI="http://download.shrapnelgames.com/downloads/${PN}_${PV}.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror bindist"
+
+RDEPEND="media-libs/libsdl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/coe
+
+# bug #430026
+QA_PREBUILT="/opt/coe2/coe_linux"
+
+src_prepare() {
+ rm -r *.{dll,exe} old || die
+ if use amd64 ; then
+ mv -f coe_linux64bit coe_linux || die
+ fi
+}
+
+src_install() {
+ insinto "${GAMES_PREFIX_OPT}/${PN}"
+ doins *.{bgm,smp,trp,trs,wrl}
+ dodoc history.txt manual.txt readme.txt
+ exeinto "${GAMES_PREFIX_OPT}/${PN}"
+ doexe coe_linux
+
+ games_make_wrapper ${PN} "./coe_linux" "${GAMES_PREFIX_OPT}/${PN}"
+ make_desktop_entry ${PN} "Conquest of Elysium 2"
+
+ # Slots for saved games.
+ # The game shows e.g. "EMPTY SLOT 0?", but it works.
+ local f slot state_dir=${GAMES_STATEDIR}/${PN}
+ dodir "${state_dir}"
+ for slot in {0..4} ; do
+ f=save${slot}
+ dosym "${state_dir}/save${slot}" "${dir}/${f}"
+ echo "empty slot ${slot}" > "${D}${state_dir}/${f}" || die "echo"
+ fperms 660 "${state_dir}/${f}"
+ done
+
+ prepgamesdirs
+}
diff --git a/games-rpg/coe2/metadata.xml b/games-rpg/coe2/metadata.xml
new file mode 100644
index 000000000000..3592b6562bab
--- /dev/null
+++ b/games-rpg/coe2/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription lang="en">
+Originally released in 1997, Conquest of Elysium II is a turn-based fantasy
+strategy game, and the precursor to the wildly popular Dominions series. As one
+of up to eight players (human, computer controlled, or a mixture) your goal, as
+suggested in the title, is very simple: total subjugation of all that do not fly
+your banner!
+
+Choose your leader from twenty distinct character classes, including brutal
+barbarians, insane necromancers, mighty maharajas, sinister shamans, and even
+the Agarthan king from Dominions 3! Each character allows new strategies for the
+player to explore. The Priestess of Baal can summon demonic creatures, change
+the weather, and sacrifice the innocent. An Enchanter can create constructs out
+of corpses, lakes, forests, and more. Barons can build siege towers, raise
+levies, and keep his subjects in line, even in times of high taxation.
+</longdescription>
+</pkgmetadata>