summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/typespeed
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/typespeed')
-rw-r--r--games-misc/typespeed/Manifest1
-rw-r--r--games-misc/typespeed/metadata.xml8
-rw-r--r--games-misc/typespeed/typespeed-0.6.5.ebuild48
3 files changed, 57 insertions, 0 deletions
diff --git a/games-misc/typespeed/Manifest b/games-misc/typespeed/Manifest
new file mode 100644
index 000000000000..487231740ffc
--- /dev/null
+++ b/games-misc/typespeed/Manifest
@@ -0,0 +1 @@
+DIST typespeed-0.6.5.tar.gz 254170 SHA256 5c860385ceed8a60f13217cc0192c4c2b4705c3e80f9866f7d72ff306eb72961 SHA512 cf3a8cdeb5fb1ee81bd5cf50d6b2aca1e7331b0bfde518c38050abae35ca617fbeed5bf2a37830a7568712ab71920f60c89197317a2721ae8c89829b0eede190 WHIRLPOOL db6b279889778573e1b2ac56b0ca1532a458ab80c768e9746d39d3717a501b921b05dc999b8f9056f35b95c850bd56c5190fa08d51a1f232de61b24ef7ab2412
diff --git a/games-misc/typespeed/metadata.xml b/games-misc/typespeed/metadata.xml
new file mode 100644
index 000000000000..712b1eb014a5
--- /dev/null
+++ b/games-misc/typespeed/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">typespeed</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-misc/typespeed/typespeed-0.6.5.ebuild b/games-misc/typespeed/typespeed-0.6.5.ebuild
new file mode 100644
index 000000000000..66dfb6aa7575
--- /dev/null
+++ b/games-misc/typespeed/typespeed-0.6.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools games
+
+DESCRIPTION="Test your typing speed, and get your fingers CPS"
+HOMEPAGE="http://typespeed.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ~ppc64 x86"
+IUSE="nls"
+
+RDEPEND="sys-libs/ncurses
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i \
+ -e 's/testsuite//' \
+ -e 's/doc//' \
+ Makefile.am \
+ || die
+ sed -i \
+ -e '/^CC =/d' \
+ src/Makefile.am \
+ || die
+ rm -rf m4 #417265
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localedir=/usr/share/locale \
+ --docdir=/usr/share/doc/${PF} \
+ --with-highscoredir="${GAMES_STATEDIR}" \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+ dodoc doc/README
+ prepgamesdirs
+}