summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /games-engines/openmw
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-engines/openmw')
-rw-r--r--games-engines/openmw/openmw-0.45.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-engines/openmw/openmw-0.45.0.ebuild b/games-engines/openmw/openmw-0.45.0.ebuild
index 6a6f448a3fc2..fe3b53da5e0d 100644
--- a/games-engines/openmw/openmw-0.45.0.ebuild
+++ b/games-engines/openmw/openmw-0.45.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg-utils readme.gentoo-r1
+inherit cmake xdg-utils readme.gentoo-r1
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
HOMEPAGE="https://openmw.org/"
@@ -50,7 +50,7 @@ BDEPEND="
S="${WORKDIR}/${PN}-${P}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# We don't install license files
sed -i '/LICDIR/d' CMakeLists.txt || die
@@ -79,14 +79,14 @@ src_configure() {
-DDESIRED_QT_VERSION=5
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use doc ; then
- cmake-utils_src_compile doc
+ cmake_src_compile doc
find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
-name '*.md5' -type f -delete || die
HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
@@ -94,7 +94,7 @@ src_compile() {
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
local DOC_CONTENTS="
You need the original Morrowind data files. If you haven't