summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-01-09 16:59:38 -0800
committerSam James <sam@gentoo.org>2024-01-21 03:59:57 +0000
commitea04e149270cb065624cd6f5fe265a6cb0749cee (patch)
tree5cc3fc3c85bb61388c9271e6a57c6d67f22e0b49 /games-emulation
parentgames-emulation/sameboy-jg: sync keywords (diff)
downloadgentoo-ea04e149270cb065624cd6f5fe265a6cb0749cee.tar.gz
gentoo-ea04e149270cb065624cd6f5fe265a6cb0749cee.tar.bz2
gentoo-ea04e149270cb065624cd6f5fe265a6cb0749cee.zip
games-emulation/sameboy-jg: add 0.16.2
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/gentoo/pull/34725 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sameboy-jg/Manifest1
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
index 29205beac02c..af96d59b4360 100644
--- a/games-emulation/sameboy-jg/Manifest
+++ b/games-emulation/sameboy-jg/Manifest
@@ -1 +1,2 @@
DIST sameboy-0.15.8.tar.bz2 3002961 BLAKE2B 5eacbc82d8c93ee85b774c554b3d3750088e8a4219d5b04daa9e6db0c70923ef823befc12831382a27ee007f117fddcfe35ff3549d7684b8587db9ffc486ccd6 SHA512 9074dfcbf400fe51e605ef0200f6ea8483650d605ab19177089c0e60f9996c15f265c5dec5fd0e6651392c9a9515e8380499e00bac837bb645220cd6ffa9c870
+DIST sameboy-0.16.2.tar.bz2 3556441 BLAKE2B 0972cb8ba200d8ac95a3d66e3b671c1adeeea71eebb4202b1985f7f72edebd42886aac48040bf034dab8d93fd52d15165551ee8dfaf6870a59ca7f574fc99e0f SHA512 bd456e248ec2d6ea0e8b017b705c829c6a94b1f7fe734769a86774c4b6983278cc5b4d61fdf8164844545bbd250b3c4f1fe725046ac7edb301268291d907f39f
diff --git a/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild b/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild
new file mode 100644
index 000000000000..c41503e9640a
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-0.16.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}