summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-10 05:22:08 +0100
committerSam James <sam@gentoo.org>2023-04-10 05:22:08 +0100
commit4f792949815ca8ea8bc71c2edaffed444ef3e5d1 (patch)
treece264f9277935d23f89f2cc9124b53ae26c1898d /games-emulation
parentgui-apps/waybar: fix build w/ gcc 13 (diff)
downloadgentoo-4f792949815ca8ea8bc71c2edaffed444ef3e5d1.tar.gz
gentoo-4f792949815ca8ea8bc71c2edaffed444ef3e5d1.tar.bz2
gentoo-4f792949815ca8ea8bc71c2edaffed444ef3e5d1.zip
games-emulation/fceux: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/900611 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fceux/fceux-2.6.5.ebuild1
-rw-r--r--games-emulation/fceux/files/fceux-2.4.0-gcc13.patch31
2 files changed, 32 insertions, 0 deletions
diff --git a/games-emulation/fceux/fceux-2.6.5.ebuild b/games-emulation/fceux/fceux-2.6.5.ebuild
index 04832332f99f..16ff86085b5c 100644
--- a/games-emulation/fceux/fceux-2.6.5.ebuild
+++ b/games-emulation/fceux/fceux-2.6.5.ebuild
@@ -36,6 +36,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-2.4.0-desktop.patch
"${FILESDIR}"/${PN}-2.4.0-no-git.patch
+ "${FILESDIR}"/${PN}-2.4.0-gcc13.patch
)
src_prepare() {
diff --git a/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch b/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch
new file mode 100644
index 000000000000..5e6348281654
--- /dev/null
+++ b/games-emulation/fceux/files/fceux-2.4.0-gcc13.patch
@@ -0,0 +1,31 @@
+https://github.com/TASEmulators/fceux/pull/629
+
+From 6ad3837eebdab597da693a39068b2c05716282be Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 10 Apr 2023 05:18:41 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes and so etc is no longer transitively included:
+```
+In file included from /var/tmp/portage/games-emulation/fceux-2.6.5/work/fceux-2.6.5/src/drivers/Qt/AboutWindow.cpp:33:
+/usr/include/x264.h:40:4: warning: #warning You must include stdint.h or inttypes.h before x264.h [-Wcpp]
+ 40 | # warning You must include stdint.h or inttypes.h before x264.h
+ | ^~~~~~~
+/usr/include/x264.h:127:5: error: uint8_t does not name a type
+ 127 | uint8_t *p_payload;
+ | ^~~~~~~
+```
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/900611
+--- a/src/drivers/Qt/AboutWindow.cpp
++++ b/src/drivers/Qt/AboutWindow.cpp
+@@ -30,6 +30,7 @@
+ #endif
+
+ #ifdef _USE_X264
++#include <cstdint>
+ #include "x264.h"
+ #endif
+