summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-12-23 08:22:35 -0800
committerMichael Orlitzky <mjo@gentoo.org>2025-02-12 02:04:59 +0000
commit2176ef7f525af21761901c7785d58eaff48dd970 (patch)
treeab17007734a07e0a7f43d3e981fa940ae59bb39d /games-emulation
parentprofiles/package.mask: mask broken fluent-icon-theme 2025.02.10 (diff)
downloadgentoo-2176ef7f525af21761901c7785d58eaff48dd970.tar.gz
gentoo-2176ef7f525af21761901c7785d58eaff48dd970.tar.bz2
gentoo-2176ef7f525af21761901c7785d58eaff48dd970.zip
games-emulation/rmg: add netplay USE flag
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/rmg/metadata.xml3
-rw-r--r--games-emulation/rmg/rmg-9999.ebuild9
2 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/rmg/metadata.xml b/games-emulation/rmg/metadata.xml
index bbbd1acac716..e951cf4242ef 100644
--- a/games-emulation/rmg/metadata.xml
+++ b/games-emulation/rmg/metadata.xml
@@ -10,9 +10,10 @@
<name>Proxy Maintainers</name>
</maintainer>
<use>
+ <flag name="angrylion-plugin">Enable the mupen64plus-video-angrylion-plus XMAME licensed plugin</flag>
<flag name="discord">Enable Discord RPC support</flag>
<flag name="dynarec">Enable the new dynarec for the mupen64plus-core plugin</flag>
- <flag name="angrylion-plugin">Enable the mupen64plus-video-angrylion-plus XMAME licensed plugin</flag>
+ <flag name="netplay">Enable Netplay</flag>
<flag name="rust-plugin">Enable the mupen64plus-input-gca rust plugin</flag>
</use>
<longdescription>
diff --git a/games-emulation/rmg/rmg-9999.ebuild b/games-emulation/rmg/rmg-9999.ebuild
index 090054fff76d..83eaf85c4da2 100644
--- a/games-emulation/rmg/rmg-9999.ebuild
+++ b/games-emulation/rmg/rmg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2024 Gentoo Authors
+# Copyright 2024-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -52,7 +52,7 @@ LICENSE="
rust-plugin? ( ISC Unicode-DFS-2016 )
"
SLOT="0"
-IUSE="angrylion-plugin discord dynarec rust-plugin"
+IUSE="angrylion-plugin discord dynarec netplay rust-plugin"
DEPEND="
dev-libs/hidapi
@@ -65,6 +65,10 @@ DEPEND="
media-libs/speexdsp
sys-libs/zlib[minizip(+)]
virtual/opengl
+ netplay? (
+ dev-qt/qtwebsockets:6
+ media-libs/sdl2-net
+ )
rust-plugin? ( dev-libs/libusb:1 )
"
RDEPEND="${DEPEND}"
@@ -124,6 +128,7 @@ src_configure() {
local mycmakeargs=(
-DAPPIMAGE_UPDATER=OFF
-DDISCORD_RPC=$(usex discord)
+ -DNETPLAY=$(usex netplay)
-DNO_ASM=$(usex dynarec OFF ON)
-DNO_RUST=$(usex rust-plugin OFF ON)
-DPORTABLE_INSTALL=OFF