summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-29 12:12:28 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-29 13:26:01 +0200
commit1c7f47eda719bb43499bec5dffc3f3e7d3ca95a1 (patch)
tree2e7e3db11ee35020fdff254d37501164b8a316e3 /games-emulation/gnuboy/files
parentgames-emulation/gngeo: Stop using games.eclass (diff)
downloadgentoo-1c7f47eda719bb43499bec5dffc3f3e7d3ca95a1.tar.gz
gentoo-1c7f47eda719bb43499bec5dffc3f3e7d3ca95a1.tar.bz2
gentoo-1c7f47eda719bb43499bec5dffc3f3e7d3ca95a1.zip
games-emulation/gnuboy: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-emulation/gnuboy/files')
-rw-r--r--games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch12
-rw-r--r--games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch36
2 files changed, 24 insertions, 24 deletions
diff --git a/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch b/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch
index b8059f915f6f..a263ee49599e 100644
--- a/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch
+++ b/games-emulation/gnuboy/files/gnuboy-1.0.3-exec-stack.patch
@@ -1,5 +1,5 @@
---- asm/i386/cpu.s
-+++ asm/i386/cpu.s
+--- a/asm/i386/cpu.s
++++ b/asm/i386/cpu.s
@@ -2428,3 +2428,6 @@
@@ -7,8 +7,8 @@
+#if defined(__linux__) && defined(__ELF__)
+.section .note.GNU-stack,"",%progbits
+#endif
---- asm/i386/lcd.s
-+++ asm/i386/lcd.s
+--- a/asm/i386/lcd.s
++++ b/asm/i386/lcd.s
@@ -288,3 +288,6 @@
@@ -16,8 +16,8 @@
+#if defined(__linux__) && defined(__ELF__)
+.section .note.GNU-stack,"",%progbits
+#endif
---- asm/i386/refresh.s
-+++ asm/i386/refresh.s
+--- a/asm/i386/refresh.s
++++ b/asm/i386/refresh.s
@@ -283,3 +283,6 @@
diff --git a/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch b/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch
index b0dd24a8e50e..543bd2434eed 100644
--- a/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch
+++ b/games-emulation/gnuboy/files/gnuboy-1.0.3-linux-headers.patch
@@ -1,7 +1,7 @@
# -ansi breaks <linux/joystick.h>
---- configure.in
-+++ configure.in
+--- a/configure.in
++++ b/configure.in
@@ -133,7 +133,7 @@
if test "$enable_warnings" = yes ; then
case "$CC" in *gcc*)
@@ -11,8 +11,8 @@
*)
AC_MSG_RESULT(disabling warnings for non-gcc compiler) ;;
esac
---- loader.c
-+++ loader.c
+--- a/loader.c
++++ b/loader.c
@@ -11,7 +11,6 @@
#include <stdlib.h>
#include <string.h>
@@ -21,8 +21,8 @@
static int mbc_table[256] =
{
---- main.c
-+++ main.c
+--- a/main.c
++++ b/main.c
@@ -8,7 +8,6 @@
#include <stdlib.h>
#include <string.h>
@@ -31,8 +31,8 @@
#include <stdarg.h>
#include <signal.h>
---- path.c
-+++ path.c
+--- a/path.c
++++ b/path.c
@@ -5,7 +5,6 @@
#include <stdlib.h>
#include <string.h>
@@ -41,8 +41,8 @@
#ifdef ALT_PATH_SEP
#define SEP ';'
---- rckeys.c
-+++ rckeys.c
+--- a/rckeys.c
++++ b/rckeys.c
@@ -4,7 +4,6 @@
#include <stdlib.h>
#include <string.h>
@@ -51,8 +51,8 @@
#include "defs.h"
#include "rc.h"
---- rcvars.c
-+++ rcvars.c
+--- a/rcvars.c
++++ b/rcvars.c
@@ -5,7 +5,6 @@
#include <stdlib.h>
#include <string.h>
@@ -61,8 +61,8 @@
#include "defs.h"
#include "rc.h"
---- sys/linux/fbdev.c
-+++ sys/linux/fbdev.c
+--- a/sys/linux/fbdev.c
++++ b/sys/linux/fbdev.c
@@ -10,7 +10,6 @@
#include <stdlib.h>
@@ -71,8 +71,8 @@
#include <unistd.h>
#include <sys/mman.h>
#include <linux/fb.h>
---- sys/linux/joy.c
-+++ sys/linux/joy.c
+--- a/sys/linux/joy.c
++++ b/sys/linux/joy.c
@@ -2,7 +2,6 @@
#include <stdio.h>
#include <stdlib.h>
@@ -81,8 +81,8 @@
#include <linux/joystick.h>
#include <sys/types.h>
#include <sys/stat.h>
---- sys/oss/oss.c
-+++ sys/oss/oss.c
+--- a/sys/oss/oss.c
++++ b/sys/oss/oss.c
@@ -2,7 +2,6 @@
#include <stdlib.h>