summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-11 20:43:25 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-11 20:56:09 +0200
commit6b8e2820ad9abbffbadf3dd62b89d5ddfc4a341a (patch)
tree32fb3cc3cdcbc6974d1ecb58c9ccfb16f11abfda /games-arcade
parentmedia-gfx/DFBPoint: Remove last-rited pkg (diff)
downloadgentoo-6b8e2820ad9abbffbadf3dd62b89d5ddfc4a341a.tar.gz
gentoo-6b8e2820ad9abbffbadf3dd62b89d5ddfc4a341a.tar.bz2
gentoo-6b8e2820ad9abbffbadf3dd62b89d5ddfc4a341a.zip
games-arcade/smc: Remove last-rited pkg
Closes: https://bugs.gentoo.org/625604
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/smc/Manifest2
-rw-r--r--games-arcade/smc/files/smc-1.9-boost150.patch101
-rw-r--r--games-arcade/smc/files/smc-1.9-underlink.patch25
-rw-r--r--games-arcade/smc/metadata.xml14
-rw-r--r--games-arcade/smc/smc-1.9.ebuild54
5 files changed, 0 insertions, 196 deletions
diff --git a/games-arcade/smc/Manifest b/games-arcade/smc/Manifest
deleted file mode 100644
index 285b6d33aa25..000000000000
--- a/games-arcade/smc/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST SMC_Music_4.1_high.zip 36605212 SHA256 0ab0e232bbdcde5c5e2391518593c5b3b2d152481946dd29d2ba7f6e22d83034 SHA512 e82e514fd2bcb0dad8973f91a40d13445498a8a0af237c83739da6b9f85d6829d9a68739677842519484cdb45e969d221cd9bb53042d0cf1981e2e5765a0da08 WHIRLPOOL c355b3440ba991f45dbda93f485282a665d8262aee00cca901807356d8cebab1deb64f6e7f79a603f8b70386a9bfa50ed41db8c9d49d995a1526db92b7c8b75a
-DIST smc-1.9.tar.bz2 49568474 SHA256 b4194e70d3f1de3da884dd1a11e4f5cec25a205f66a3b85cc9fc1c86289b237d SHA512 f7fdb3dd48e2c4503158e5237911906d1de23b9c8ac0f494affa6e79eb57620c61cc757e4ba6e83fdd556fc5ee061b42be0b27055deb96e9d6e5b3ea8199124e WHIRLPOOL 9bf6ea2a7db552200e57b10968ffa13ae524b91c868fc3c5d45f7ab2ee7c547563b5f337f536183538369bde86530b272befb1601b551739b62acc71305fc697
diff --git a/games-arcade/smc/files/smc-1.9-boost150.patch b/games-arcade/smc/files/smc-1.9-boost150.patch
deleted file mode 100644
index 42d7ce2bc66c..000000000000
--- a/games-arcade/smc/files/smc-1.9-boost150.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- src/overworld/world_manager.cpp.old 2012-11-14 17:05:19.759087973 +0100
-+++ src/overworld/world_manager.cpp 2012-11-14 17:06:55.365644219 +0100
-@@ -111,14 +111,14 @@
- void cOverworld_Manager :: Load_Dir( const std::string &dir, bool user_dir /* = 0 */ )
- {
- // set world directory
-- fs::path full_path( dir, fs::native );
-+ fs::path full_path( dir );
- fs::directory_iterator end_iter;
-
- for( fs::directory_iterator dir_itr( full_path ); dir_itr != end_iter; ++dir_itr )
- {
- try
- {
-- std::string current_dir = dir_itr->path().leaf();
-+ std::string current_dir = dir_itr->path().filename().string();
-
- // only directories with an existing description
- if( fs::is_directory( *dir_itr ) && File_Exists( dir + "/" + current_dir + "/description.xml" ) )
---- src/video/video.cpp.old 2012-11-14 17:10:26.448625365 +0100
-+++ src/video/video.cpp 2012-11-14 17:11:37.486580531 +0100
-@@ -749,7 +749,7 @@
- {
- try
- {
-- fs::remove_all( fs::path( m_imgcache_dir, fs::native ) );
-+ fs::remove_all( fs::path( m_imgcache_dir ) );
- }
- // could happen if a file is locked or we have no write rights
- catch( const std::exception &ex )
-@@ -771,7 +771,7 @@
- // no cache available
- if( !Dir_Exists( imgcache_dir_active ) )
- {
-- fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR, fs::native ) );
-+ fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR ) );
- }
- // cache available
- else
---- src/core/filesystem/filesystem.cpp.old 2012-11-14 09:00:41.965617165 +0100
-+++ src/core/filesystem/filesystem.cpp 2012-11-14 16:57:11.282043980 +0100
-@@ -64,7 +64,7 @@
-
- bool Dir_Exists( const std::string &dir )
- {
-- return fs::exists( fs::path( dir, fs::native ) );
-+ return fs::exists( fs::path( dir ) );
-
- /*struct stat file_info;
-
-@@ -89,7 +89,7 @@
-
- bool Create_Directory( const std::string &dir )
- {
-- return fs::create_directory( fs::path( dir, fs::native ) );
-+ return fs::create_directory( fs::path( dir ) );
- }
-
- size_t Get_File_Size( const std::string &filename )
-@@ -130,7 +130,7 @@
- {
- vector<std::string> valid_files;
-
-- fs::path full_path( dir, fs::native );
-+ fs::path full_path( dir );
- fs::directory_iterator end_iter;
-
- // load all available objects
-@@ -142,27 +142,27 @@
- if( fs::is_directory( *dir_itr ) )
- {
- // ignore hidden directories
-- if( dir_itr->path().leaf().find( "." ) == 0 )
-+ if( dir_itr->path().filename().string().find( "." ) == 0 )
- {
- continue;
- }
-
- if( with_directories )
- {
-- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
-+ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
- }
-
- // load all items from the sub-directory
- if( search_in_sub_directories )
- {
-- vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().leaf(), file_type, with_directories );
-+ vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().filename().string(), file_type, with_directories );
- valid_files.insert( valid_files.end(), new_valid_files.begin(), new_valid_files.end() );
- }
- }
- // valid file
-- else if( file_type.empty() || dir_itr->path().leaf().rfind( file_type ) != std::string::npos )
-+ else if( file_type.empty() || dir_itr->path().filename().string().rfind( file_type ) != std::string::npos )
- {
-- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
-+ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
- }
- }
- catch( const std::exception &ex )
diff --git a/games-arcade/smc/files/smc-1.9-underlink.patch b/games-arcade/smc/files/smc-1.9-underlink.patch
deleted file mode 100644
index 6e076027c472..000000000000
--- a/games-arcade/smc/files/smc-1.9-underlink.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-diff -burN smc-1.9.orig/configure.ac smc-1.9/configure.ac
---- smc-1.9.orig/configure.ac 2013-10-23 19:11:08.635054067 +0200
-+++ smc-1.9/configure.ac 2013-10-23 19:42:29.820272295 +0200
-@@ -12,6 +12,10 @@
- ### Check for libraries ###
-
- # Check for the Boost Filesystem library
-+AC_CHECK_LIB(boost_system, main, ,
-+ AC_MSG_ERROR([Unable to find Boost System library]))
-+
-+# Check for the Boost Filesystem library
- AC_CHECK_LIB(boost_filesystem, main, ,
- AC_MSG_ERROR([Unable to find Boost Filesystem library]))
-
-@@ -36,6 +40,10 @@
- CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
- LIBS="$LIBS $SDL_LIBS"
-
-+# Check for the X11 library
-+AC_CHECK_LIB(X11, XOpenDisplay, ,
-+ AC_MSG_ERROR([X11 library not found]))
-+
- # Check for the libpng library
- AC_CHECK_LIB(png, png_init_io, ,
- AC_MSG_ERROR([libpng library not found]))
diff --git a/games-arcade/smc/metadata.xml b/games-arcade/smc/metadata.xml
deleted file mode 100644
index fd7e435280ef..000000000000
--- a/games-arcade/smc/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
- </maintainer>
- <use>
- <flag name="music">Download and install the music files</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">smclone</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/games-arcade/smc/smc-1.9.ebuild b/games-arcade/smc/smc-1.9.ebuild
deleted file mode 100644
index 1a068441397e..000000000000
--- a/games-arcade/smc/smc-1.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit autotools eutils flag-o-matic games
-
-MUSIC_P=SMC_Music_4.1_high
-DESCRIPTION="Secret Maryo Chronicles"
-HOMEPAGE="http://www.secretmaryo.org/"
-SRC_URI="mirror://sourceforge/smclone/${P}.tar.bz2
- music? ( mirror://sourceforge/smclone/${MUSIC_P}.zip )"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="music"
-
-RDEPEND="<dev-games/cegui-0.7[opengl,devil]
- dev-libs/boost
- virtual/opengl
- virtual/glu
- x11-libs/libX11
- dev-libs/libpcre[unicode]
- media-libs/libpng:0
- media-libs/libsdl[X,joystick,opengl]
- media-libs/sdl-image[png]
- media-libs/sdl-mixer[vorbis]
- media-libs/sdl-ttf"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- music? ( app-arch/unzip )"
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd "${S}"
- use music && unpack ${MUSIC_P}.zip
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-boost150.patch \
- "${FILESDIR}"/${P}-underlink.patch
- eautoreconf
-}
-
-src_install() {
- default
- newicon data/icon/window_32.png smc.png
- make_desktop_entry ${PN} "Secret Maryo Chronicles"
- doman makefiles/unix/man/smc.6
- dodoc docs/*.txt
- dohtml docs/{*.css,*.html}
- prepgamesdirs
-}