summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/rocksndiamonds/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/rocksndiamonds/files')
-rw-r--r--games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-parallel-build.patch12
-rw-r--r--games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-perms.patch29
2 files changed, 41 insertions, 0 deletions
diff --git a/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-parallel-build.patch b/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-parallel-build.patch
new file mode 100644
index 000000000000..0aa709652129
--- /dev/null
+++ b/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-parallel-build.patch
@@ -0,0 +1,12 @@
+diff -ru rocksndiamonds-3.3.1.2.orig/src/Makefile rocksndiamonds-3.3.1.2/src/Makefile
+--- rocksndiamonds-3.3.1.2.orig/src/Makefile 2013-11-24 08:05:56.000000000 -0500
++++ rocksndiamonds-3.3.1.2/src/Makefile 2014-12-31 15:47:37.539941795 -0500
+@@ -255,7 +255,7 @@
+ # build targets
+ # -----------------------------------------------------------------------------
+
+-all: $(AUTOCONF) libgame_dir game_em_dir game_sp_dir $(PROGNAME)
++all: $(PROGNAME)
+
+ $(PROGNAME): $(RNDLIBS) $(TIMESTAMP_FILE) $(OBJS) $(ICON)
+ $(CC) $(PROFILING) $(OBJS) $(ICON) $(RNDLIBS) $(LDFLAGS) -o $(PROGNAME)
diff --git a/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-perms.patch b/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-perms.patch
new file mode 100644
index 000000000000..65a06e6cdf77
--- /dev/null
+++ b/games-arcade/rocksndiamonds/files/rocksndiamonds-3.3.1.2-perms.patch
@@ -0,0 +1,29 @@
+diff -up rocksndiamonds-3.3.0.1/src/libgame/setup.c.CVE-2011-4606 rocksndiamonds-3.3.0.1/src/libgame/setup.c
+--- rocksndiamonds-3.3.0.1/src/libgame/setup.c.CVE-2011-4606 2011-12-12 14:28:30.083078680 -0500
++++ rocksndiamonds-3.3.0.1/src/libgame/setup.c 2011-12-12 14:34:36.758744753 -0500
+@@ -1293,11 +1293,14 @@ void sortTreeInfo(TreeInfo **node_first)
+ #define MODE_W_ALL (S_IWUSR | S_IWGRP | S_IWOTH)
+ #define MODE_X_ALL (S_IXUSR | S_IXGRP | S_IXOTH)
+
++#define MODE_R_PRIVATE (S_IRUSR)
+ #define MODE_W_PRIVATE (S_IWUSR)
++#define MODE_X_PRIVATE (S_IXUSR)
++
+ #define MODE_W_PUBLIC (S_IWUSR | S_IWGRP)
+ #define MODE_W_PUBLIC_DIR (S_IWUSR | S_IWGRP | S_ISGID)
+
+-#define DIR_PERMS_PRIVATE (MODE_R_ALL | MODE_X_ALL | MODE_W_PRIVATE)
++#define DIR_PERMS_PRIVATE (MODE_R_PRIVATE | MODE_X_PRIVATE | MODE_W_PRIVATE)
+ #define DIR_PERMS_PUBLIC (MODE_R_ALL | MODE_X_ALL | MODE_W_PUBLIC_DIR)
+
+ #define FILE_PERMS_PRIVATE (MODE_R_ALL | MODE_W_PRIVATE)
+@@ -1456,7 +1459,8 @@ void createDirectory(char *dir, char *te
+ if (running_setgid)
+ posix_umask(last_umask & group_umask);
+ else
+- dir_mode |= MODE_W_ALL;
++ if (permission_class == PERMS_PUBLIC)
++ dir_mode |= MODE_W_ALL;
+
+ if (!fileExists(dir))
+ if (posix_mkdir(dir, dir_mode) != 0)