summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-10-19 19:09:07 -0300
committerPacho Ramos <pacho@gentoo.org>2023-12-20 10:53:23 +0100
commitb9cd6bf195da3e9f0945f7e8aaa5d50b85d70c9f (patch)
tree6644baf6c81b990b98af2f2444886add19cbd573 /games-arcade/gnome-nibbles
parentdev-java/auto-service-annotations: new package, add 1.1.1 (diff)
downloadgentoo-b9cd6bf195da3e9f0945f7e8aaa5d50b85d70c9f.tar.gz
gentoo-b9cd6bf195da3e9f0945f7e8aaa5d50b85d70c9f.tar.bz2
gentoo-b9cd6bf195da3e9f0945f7e8aaa5d50b85d70c9f.zip
games-arcade/gnome-nibbles: Version bump to 4.0.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33422 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'games-arcade/gnome-nibbles')
-rw-r--r--games-arcade/gnome-nibbles/Manifest1
-rw-r--r--games-arcade/gnome-nibbles/gnome-nibbles-4.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/games-arcade/gnome-nibbles/Manifest b/games-arcade/gnome-nibbles/Manifest
index fee0c94d9dc6..180ce5ccdaa5 100644
--- a/games-arcade/gnome-nibbles/Manifest
+++ b/games-arcade/gnome-nibbles/Manifest
@@ -1 +1,2 @@
DIST gnome-nibbles-3.38.3.tar.xz 388996 BLAKE2B cb8482568e5a9e87d2ff974ab9c1a7a33d353554a3bf56774dd451da06cfe97267ae82c90d8331563886c1051e0d59693785773b31247c450c795c05e748854c SHA512 08102ab6a48cc121b2ea4d0edc32e3ee7b0eb56441d061367ca7c058cf94046fe185767999b262c9aaeac70e2086333f024b70ba85810e4275a9cbdede5dacee
+DIST gnome-nibbles-4.0.1.tar.xz 417716 BLAKE2B 18703fb353097c75b0a36caaca60ae2d2a2186920cfe5d8bcb67d594608beee29de46f70557ff37e0edd819e6838acfc98250c568605e2f657627c60ea56ae5f SHA512 802bf7f320613b3a1d57cbe7ab804ba07781ad3c5e6ea3e5d1d2ee0d744055265b05895987d84714ca6eeb7eca832f138a2427f5c00d25ef14c8ef8976ddae2f
diff --git a/games-arcade/gnome-nibbles/gnome-nibbles-4.0.1.ebuild b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.1.ebuild
new file mode 100644
index 000000000000..2d8c493922ca
--- /dev/null
+++ b/games-arcade/gnome-nibbles/gnome-nibbles-4.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Nibbles clone for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nibbles https://gitlab.gnome.org/GNOME/gnome-nibbles"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ dev-libs/libgee:0.8=
+ >=media-libs/gsound-1.0.2
+ >=gui-libs/gtk-4.6:4
+ x11-libs/pango
+ >=dev-libs/libgnome-games-support-2.0.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+"
+
+src_unpack() {
+ default
+ mv "${WORKDIR}"/gnome-nibbles-4.0.rc2 "${WORKDIR}"/gnome-nibbles-4.0.rc.2
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}