summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-01 14:14:54 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-01 14:16:21 -0400
commitadb5f657fb91acbf5b4f6354ab5bc2cea436ac59 (patch)
tree9f7862598242006a210c50fd94342b10c619e2fe /games-arcade/gnome-nibbles
parentdev-libs/libdnet: properly conditionally build tests (diff)
downloadgentoo-adb5f657fb91acbf5b4f6354ab5bc2cea436ac59.tar.gz
gentoo-adb5f657fb91acbf5b4f6354ab5bc2cea436ac59.tar.bz2
gentoo-adb5f657fb91acbf5b4f6354ab5bc2cea436ac59.zip
games-arcade/gnome-nibbles: Version bump to 3.38.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'games-arcade/gnome-nibbles')
-rw-r--r--games-arcade/gnome-nibbles/Manifest1
-rw-r--r--games-arcade/gnome-nibbles/gnome-nibbles-3.38.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/games-arcade/gnome-nibbles/Manifest b/games-arcade/gnome-nibbles/Manifest
index 3e2c99cd2462..b8d24f6cfb2b 100644
--- a/games-arcade/gnome-nibbles/Manifest
+++ b/games-arcade/gnome-nibbles/Manifest
@@ -1 +1,2 @@
DIST gnome-nibbles-3.38.2.tar.xz 337680 BLAKE2B 96ca3794d72f600608b049aafe83808e917ec8e8462b19d31af36f2570e6c3fc8b3c9e85cbaa4ec9f041ecb934aa99701d13fcf232c447f5a4f51e6a98a66173 SHA512 e0146e33efa20ca48131be76a7f1738f8e3e2503a152c879e1d0d6accb091f9c4cb36c6d3009ca824bf6c4ac0ff5249b17e6423919c615992f0c4bef6dfcd601
+DIST gnome-nibbles-3.38.3.tar.xz 388996 BLAKE2B cb8482568e5a9e87d2ff974ab9c1a7a33d353554a3bf56774dd451da06cfe97267ae82c90d8331563886c1051e0d59693785773b31247c450c795c05e748854c SHA512 08102ab6a48cc121b2ea4d0edc32e3ee7b0eb56441d061367ca7c058cf94046fe185767999b262c9aaeac70e2086333f024b70ba85810e4275a9cbdede5dacee
diff --git a/games-arcade/gnome-nibbles/gnome-nibbles-3.38.3.ebuild b/games-arcade/gnome-nibbles/gnome-nibbles-3.38.3.ebuild
new file mode 100644
index 000000000000..1c2ab9fe52fa
--- /dev/null
+++ b/games-arcade/gnome-nibbles/gnome-nibbles-3.38.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Nibbles clone for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nibbles https://gitlab.gnome.org/GNOME/gnome-nibbles"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.42.0:2
+ >=media-libs/clutter-1.22.0:1.0
+ >=media-libs/clutter-gtk-1.4.0:1.0
+ dev-libs/libgee:0.8=
+ >=media-libs/gsound-1.0.2
+ >=x11-libs/gtk+-3.24.0:3
+ >=dev-libs/libgnome-games-support-1.7.1:1=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ media-libs/gsound[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}