summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2021-07-25 18:48:28 +0200
committerIonen Wolkens <ionen@gentoo.org>2021-07-27 14:18:35 -0400
commit2e3a978a048a55058204d792e451d13eaa547c78 (patch)
tree0c1eb6f0e71280d63aecf0012e84d60b12ccc5a1 /games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild
parentgames-rpg/lure: EAPI8 bump, ebuild improvements (diff)
downloadgentoo-2e3a978a048a55058204d792e451d13eaa547c78.tar.gz
gentoo-2e3a978a048a55058204d792e451d13eaa547c78.tar.bz2
gentoo-2e3a978a048a55058204d792e451d13eaa547c78.zip
games-arcade/ascii-invaders: EAPI8, version bump (1.0.1)
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild')
-rw-r--r--games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild b/games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild
new file mode 100644
index 000000000000..f83820061e2e
--- /dev/null
+++ b/games-arcade/ascii-invaders/ascii-invaders-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Space invaders clone, using ncurses library"
+HOMEPAGE="https://github.com/macdice/ascii-invaders"
+SRC_URI="https://github.com/macdice/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc64 ~x86 ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ tc-export CC
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags ncurses || die)
+ emake -f /dev/null LDLIBS="$($(tc-getPKG_CONFIG) ncurses --libs || die)" invaders
+}
+
+src_install() {
+ newbin invaders ${PN}
+ einstalldocs
+}