summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-14 23:25:24 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-14 23:25:24 +0100
commitdc3715e54ff4f1549576cd25fb6abeaeb7f9ef11 (patch)
tree7761569658a8c423995ee5e09c21e6cfdf8d017e /games-action
parentdev-db/pg_background: new package (diff)
downloadgentoo-dc3715e54ff4f1549576cd25fb6abeaeb7f9ef11.tar.gz
gentoo-dc3715e54ff4f1549576cd25fb6abeaeb7f9ef11.tar.bz2
gentoo-dc3715e54ff4f1549576cd25fb6abeaeb7f9ef11.zip
games-action/descent2-data: Fix patching the CD readme file
Closes: https://bugs.gentoo.org/933992 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/descent2-data/descent2-data-1.2-r1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/games-action/descent2-data/descent2-data-1.2-r1.ebuild b/games-action/descent2-data/descent2-data-1.2-r1.ebuild
index 5b81d07228cc..8f19d07739b9 100644
--- a/games-action/descent2-data/descent2-data-1.2-r1.ebuild
+++ b/games-action/descent2-data/descent2-data-1.2-r1.ebuild
@@ -97,10 +97,14 @@ src_prepare() {
# Patch to 1.2 if necessary
if use cdinstall; then
if [[ $(md5sum data/descent2.ham) != 7f30c3d7d4087b8584b49012a53ce022* ]]; then
- local i
- for i in *.xdelta; do
- xdelta3 -d -s data/"${i%.*}" "${i}" data/"${i%.*}".new || die
- mv data/"${i%.*}"{.new,} || die
+ local x dir
+ for x in *.xdelta; do
+ case "${x}" in
+ *.txt.xdelta) dir=doc ;;
+ *) dir=data ;;
+ esac
+ xdelta3 -d -s "${dir}/${x%.*}" "${x}" "${dir}/${x%.*}.new" || die
+ mv "${dir}/${x%.*}"{.new,} || die
done
fi
fi