summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-04-20 17:28:01 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-04-22 19:23:26 +0200
commit4b3e0246ce71b8e29fbf73f6280d5cff860d258f (patch)
tree2965a3cb7e95e5b97fc11a0cfb6fa83f9367c215 /games-action
parentnet-wireless/uhd: add 4.2.0.0 (diff)
downloadgentoo-4b3e0246ce71b8e29fbf73f6280d5cff860d258f.tar.gz
gentoo-4b3e0246ce71b8e29fbf73f6280d5cff860d258f.tar.bz2
gentoo-4b3e0246ce71b8e29fbf73f6280d5cff860d258f.zip
games-action/polymc: adds version 1.2.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/Manifest1
-rw-r--r--games-action/polymc/files/polymc-iconfix.patch29
-rw-r--r--games-action/polymc/metadata.xml3
-rw-r--r--games-action/polymc/polymc-1.2.1.ebuild113
-rw-r--r--games-action/polymc/polymc-9999.ebuild47
5 files changed, 172 insertions, 21 deletions
diff --git a/games-action/polymc/Manifest b/games-action/polymc/Manifest
index b44203e704b5..98093b7fbfd2 100644
--- a/games-action/polymc/Manifest
+++ b/games-action/polymc/Manifest
@@ -1 +1,2 @@
DIST polymc-1.1.1.tar.gz 5116164 BLAKE2B ca251cac3c8ea21de8a59297a0e637dac078d751476fec5fe86696df270c63ff079779056f016fa656506ea205bb7ace50ab6e0df190ffca14e43297b92292af SHA512 db32479e9e8a92ec61292c97281673b3084e1085d29b764214834de872d9eddf2ed1d2e383bcd79197e0c9321eec025af652b12c863596ff6abb0f5fba9a7af5
+DIST polymc-1.2.1.tar.gz 5157547 BLAKE2B 92a65cd1303b4f2dce299d2a40824de54babd47bd21a894827e7a0e94276551fc747873ba44e63ac13b3ca46649c3d5280ec9eecd92eb63678f8cbc3c27e4f69 SHA512 193415b552dbc3f540f481c22e36c2b9d0604757cb12283ec0fc2979246757937648b76821818f0742b3f5201ed7af8e535dff9ef3d5efcb22f7a1ddf9ee67d2
diff --git a/games-action/polymc/files/polymc-iconfix.patch b/games-action/polymc/files/polymc-iconfix.patch
new file mode 100644
index 000000000000..01477e559ff6
--- /dev/null
+++ b/games-action/polymc/files/polymc-iconfix.patch
@@ -0,0 +1,29 @@
+From 8f494636afb9a9b9c0619b256252d3a9dcdbab72 Mon Sep 17 00:00:00 2001
+From: flow <thiagodonato300@gmail.com>
+Date: Thu, 21 Apr 2022 06:38:18 -0300
+Subject: [PATCH] fix: Build iconfix as static library
+
+Otherwise the launcher is unable to find the iconfix .so, and so the
+launcher doesn't run.
+
+Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com>
+---
+ libraries/iconfix/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libraries/iconfix/CMakeLists.txt b/libraries/iconfix/CMakeLists.txt
+index 08441203..97a59129 100644
+--- a/libraries/iconfix/CMakeLists.txt
++++ b/libraries/iconfix/CMakeLists.txt
+@@ -12,7 +12,7 @@ internal/qiconloader.cpp
+ internal/qiconloader_p.h
+ )
+
+-add_library(Launcher_iconfix ${ICONFIX_SOURCES})
++add_library(Launcher_iconfix STATIC ${ICONFIX_SOURCES})
+ target_include_directories(Launcher_iconfix PUBLIC ${CMAKE_CURRENT_SOURCE_DIR} "${CMAKE_CURRENT_BINARY_DIR}" )
+
+ target_link_libraries(Launcher_iconfix Qt5::Core Qt5::Widgets)
+--
+2.35.1
+
diff --git a/games-action/polymc/metadata.xml b/games-action/polymc/metadata.xml
index 78a705414ef3..f704149126f6 100644
--- a/games-action/polymc/metadata.xml
+++ b/games-action/polymc/metadata.xml
@@ -23,4 +23,7 @@
<remote-id type="github">PolyMC/PolyMC</remote-id>
</upstream>
<longdescription>PolyMC is a multi-instance Minecraft launcher focused on user freedom, redistributability, and simplicity.</longdescription>
+ <use>
+ <flag name="lto">Enable link-time optimization</flag>
+ </use>
</pkgmetadata>
diff --git a/games-action/polymc/polymc-1.2.1.ebuild b/games-action/polymc/polymc-1.2.1.ebuild
new file mode 100644
index 000000000000..d488a775fb9a
--- /dev/null
+++ b/games-action/polymc/polymc-1.2.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake java-pkg-2 optfeature xdg
+
+HOMEPAGE="https://polymc.org/ https://github.com/PolyMC/PolyMC"
+DESCRIPTION="A custom, open source Minecraft launcher"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="
+ https://github.com/PolyMC/PolyMC
+ https://github.com/PolyMC/libnbtplusplus
+ "
+
+ EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
+else
+ MY_PN="PolyMC"
+
+ # Let's use the vendored tarball to avoid dealing with the submodules directly
+ SRC_URI="
+ https://github.com/PolyMC/PolyMC/releases/download/${PV}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz
+ "
+
+ # The PolyMC's files are unpacked to ${WORKDIR}/PolyMC-${PV}
+ S="${WORKDIR}/${MY_PN}-${PV}"
+
+ KEYWORDS="~amd64"
+fi
+
+# Apache-2.0 for MultiMC (PolyMC is forked from it)
+# GPL-3 for PolyMC
+# LGPL-3 for libnbtplusplus
+# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
+
+SLOT="0"
+
+IUSE="debug lto"
+REQUIRED_USE="
+ lto? ( !debug )
+"
+
+MIN_QT="5.6.0"
+
+QT_DEPS="
+ >=dev-qt/qtconcurrent-${MIN_QT}:5
+ >=dev-qt/qtcore-${MIN_QT}:5
+ >=dev-qt/qtgui-${MIN_QT}:5
+ >=dev-qt/qtnetwork-${MIN_QT}:5
+ >=dev-qt/qttest-${MIN_QT}:5
+ >=dev-qt/qtwidgets-${MIN_QT}:5
+ >=dev-qt/qtxml-${MIN_QT}:5
+"
+
+# Required at both build-time and run-time
+COMMON_DEPENDS="
+ ${QT_DEPS}
+ >=dev-libs/quazip-1.3:=
+ sys-libs/zlib
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
+ >=virtual/jdk-1.8.0:*
+"
+
+# At run-time we don't depend on JDK, only JRE
+# And we need more than just the GL headers
+RDEPEND="
+ ${COMMON_DEPENDS}
+ >=virtual/jre-1.8.0:*
+ virtual/opengl
+"
+
+PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure(){
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ # Resulting binary is named polymc
+ -DLauncher_APP_BINARY_NAME="${PN}"
+
+ -DENABLE_LTO=$(usex lto)
+ )
+
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
+ cmake_src_configure
+}
+
+src_compile(){
+ cmake_src_compile
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ # https://github.com/PolyMC/PolyMC/issues/227
+ optfeature "old Minecraft (<= 1.12.2) support" x11-libs/libXrandr
+}
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
index d036cb15c635..d488a775fb9a 100644
--- a/games-action/polymc/polymc-9999.ebuild
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -13,12 +13,10 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="
https://github.com/PolyMC/PolyMC
- https://github.com/MultiMC/libnbtplusplus
- https://github.com/stachenov/quazip
+ https://github.com/PolyMC/libnbtplusplus
"
- # Include all submodules
- EGIT_SUBMODULES=( '*' )
+ EGIT_SUBMODULES=( 'depends/libnbtplusplus' )
else
MY_PN="PolyMC"
@@ -36,13 +34,15 @@ fi
# Apache-2.0 for MultiMC (PolyMC is forked from it)
# GPL-3 for PolyMC
# LGPL-3 for libnbtplusplus
-# LGPL-2.1 with linking exception for Quazip
# See the rest of PolyMC's libraries at https://github.com/PolyMC/PolyMC/tree/develop/libraries
-LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 LGPL-2.1-with-linking-exception OFL-1.1 MIT"
+LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
SLOT="0"
-IUSE="debug"
+IUSE="debug lto"
+REQUIRED_USE="
+ lto? ( !debug )
+"
MIN_QT="5.6.0"
@@ -56,43 +56,48 @@ QT_DEPS="
>=dev-qt/qtxml-${MIN_QT}:5
"
-DEPEND="
+# Required at both build-time and run-time
+COMMON_DEPENDS="
${QT_DEPS}
- media-libs/libglvnd
+ >=dev-libs/quazip-1.3:=
sys-libs/zlib
+"
+
+DEPEND="
+ ${COMMON_DEPENDS}
+ media-libs/libglvnd
>=virtual/jdk-1.8.0:*
"
# At run-time we don't depend on JDK, only JRE
# And we need more than just the GL headers
RDEPEND="
- ${QT_DEPS}
- sys-libs/zlib
+ ${COMMON_DEPENDS}
>=virtual/jre-1.8.0:*
virtual/opengl
"
+PATCHES=( "${FILESDIR}/${PN}-iconfix.patch" )
+
src_prepare() {
cmake_src_prepare
}
src_configure(){
- if use debug; then
- CMAKE_BUILD_TYPE=Debug
- else
- # Prepare for LTO in 1.2.0 (?)
- # See https://github.com/PolyMC/PolyMC/pull/333
- CMAKE_BUILD_TYPE=Release
- fi
-
local mycmakeargs=(
- # Do a system install
- -DLauncher_PORTABLE=0
-DCMAKE_INSTALL_PREFIX="/usr"
# Resulting binary is named polymc
-DLauncher_APP_BINARY_NAME="${PN}"
+
+ -DENABLE_LTO=$(usex lto)
)
+ if use debug; then
+ CMAKE_BUILD_TYPE=Debug
+ else
+ CMAKE_BUILD_TYPE=Release
+ fi
+
cmake_src_configure
}