summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-14 18:33:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-14 22:40:36 -0400
commit2fc2e16c0ed4057ca455e1a684cb9a1838f64d65 (patch)
tree025f3e184d3123fe594778c50691b269931793f0 /games-action/geki3-KXL/files
parentgames-action/geki2-KXL: EAPI6->8, fix clang/fonts, cleanup patches (diff)
downloadgentoo-2fc2e16c0ed4057ca455e1a684cb9a1838f64d65.tar.gz
gentoo-2fc2e16c0ed4057ca455e1a684cb9a1838f64d65.tar.bz2
gentoo-2fc2e16c0ed4057ca455e1a684cb9a1838f64d65.zip
games-action/geki3-KXL: EAPI6->8, fix clang/fonts, cleanup patches
Removed paths patch that was mostly for /usr/games, and instead require a smaller workaround to install-data and remove .score. Also fix description, this is a different game than geki2 (horizontal). Add media-fonts/font-bitstream-100dpi as it'd crash (later) without. Closes: https://bugs.gentoo.org/730854 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-action/geki3-KXL/files')
-rw-r--r--games-action/geki3-KXL/files/geki3-KXL-1.0.3-cflags.patch9
-rw-r--r--games-action/geki3-KXL/files/geki3-KXL-1.0.3-clang.patch20
-rw-r--r--games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch41
3 files changed, 29 insertions, 41 deletions
diff --git a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-cflags.patch b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-cflags.patch
new file mode 100644
index 000000000000..952b4bf6d746
--- /dev/null
+++ b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-cflags.patch
@@ -0,0 +1,9 @@
+https://bugs.gentoo.org/426890
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -5,4 +5,4 @@
+ ranking.c ranking.h your.c your.h
+
+-CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
++AM_CFLAGS = @X_CFLAGS@ @KXL_CFLAGS@
+ LIBS = @X_LIBS@ -lX11 @KXL_LIBS@ -lKXL
diff --git a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-clang.patch b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-clang.patch
new file mode 100644
index 000000000000..ad84615a398a
--- /dev/null
+++ b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-clang.patch
@@ -0,0 +1,20 @@
+Use void so that clang does not complain about missing (unused)
+return value, and also add missing string.h.
+https://bugs.gentoo.org/730854
+--- a/src/ranking.c
++++ b/src/ranking.c
+@@ -1,2 +1,3 @@
+ #include <pwd.h>
++#include <string.h>
+ #include "geki3.h"
+@@ -7,3 +8,3 @@
+ **********************/
+-int ScoreRanking(void)
++void ScoreRanking(void)
+ {
+--- a/src/ranking.h
++++ b/src/ranking.h
+@@ -3,2 +3,3 @@
+
++void ScoreRanking(void);
+ void RankingScore(void);
diff --git a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch b/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
deleted file mode 100644
index 26f3f4371b85..000000000000
--- a/games-action/geki3-KXL/files/geki3-KXL-1.0.3-paths.patch
+++ /dev/null
@@ -1,41 +0,0 @@
---- a/bmp/Makefile.am
-+++ b/bmp/Makefile.am
-@@ -1,4 +1,4 @@
--bmpdir = $(prefix)/share/geki3/bmp
-+bmpdir = $(BMP_PATH)
- bmp_DATA = back1.bmp boss2.bmp enemyshot1.bmp missile.bmp\
- pata.bmp back2.bmp boss3.bmp enemyshot2.bmp mogu.bmp\
- pata_ball.bmp back3.bmp boss4.bmp frame.bmp mogu_ball.bmp\
---- a/configure.in
-+++ b/configure.in
-@@ -25,9 +25,9 @@
- BMP_PATH=/usr/local/share/geki3/bmp
- WAV_PATH=/usr/local/share/geki3/wav
- else
-- DATA_PATH=$prefix/share/geki3/data
-- BMP_PATH=$prefix/share/geki3/bmp
-- WAV_PATH=$prefix/share/geki3/wav
-+ DATA_PATH=$datadir/geki3/data
-+ BMP_PATH=$datadir/geki3/bmp
-+ WAV_PATH=$datadir/geki3/wav
- fi
- AC_DEFINE_UNQUOTED(DATA_PATH,"$DATA_PATH")
- AC_DEFINE_UNQUOTED(BMP_PATH,"$BMP_PATH")
---- a/data/Makefile.am
-+++ b/data/Makefile.am
-@@ -1,6 +1,4 @@
--datadir = $(prefix)/share/geki3/data
-+datadir = $(DATA_PATH)
- data_DATA = stage1.dat stage2.dat stage3.dat stage4.dat
- EXTRA_DIST = stage1.dat stage2.dat stage3.dat stage4.dat .score
-
--install:
-- $(INSTALL) -c -m 666 ./.score $(DESTDIR)$(DATA_PATH)
---- a/wav/Makefile.am
-+++ b/wav/Makefile.am
-@@ -1,4 +1,4 @@
--wavdir = $(prefix)/share/geki3/wav
-+wavdir = $(WAV_PATH)
- wav_DATA = bgm1.wav bgm2.wav bgm3.wav bgm4.wav boom.wav boss.wav go.wav \
- laser.wav open.wav pow.wav warning.wav
- EXTRA_DIST = bgm1.wav bgm2.wav bgm3.wav bgm4.wav boom.wav boss.wav go.wav \