summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-05-29 08:57:59 -0400
committerMike Gilbert <floppym@gentoo.org>2016-06-05 12:47:11 -0400
commitda4e991e2ac745a1d202b964072b69d3bf4bbd01 (patch)
treeee8d4e9730e4a3272f9ee22c065585af35e021e5 /eclass/distutils-r1.eclass
parentdistutils-r1.eclass: Move creation of .pydistutils.cfg to esetup.py (diff)
downloadgentoo-da4e991e2ac745a1d202b964072b69d3bf4bbd01.tar.gz
gentoo-da4e991e2ac745a1d202b964072b69d3bf4bbd01.tar.bz2
gentoo-da4e991e2ac745a1d202b964072b69d3bf4bbd01.zip
distutils-r1.eclass: Do not modify the HOME variable
This was only necessary when we ran phases in parallel. Also, PMS says this variable should not be modified.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass6
1 files changed, 0 insertions, 6 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 334ce73a6503..c5452906e2bd 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -637,12 +637,6 @@ distutils-r1_run_phase() {
# in the sys.path_importer_cache)
mkdir -p "${BUILD_DIR}/lib" || die
- # We need separate home for each implementation, for .pydistutils.cfg.
- if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
- local -x HOME=${HOME}/${EPYTHON}
- mkdir -p "${HOME}" || die
- fi
-
# Set up build environment, bug #513664.
local -x AR=${AR} CC=${CC} CPP=${CPP} CXX=${CXX}
tc-export AR CC CPP CXX