summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-06-02 16:33:58 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-06-02 16:34:14 -0500
commit8630ff7219b315f4a48bb3db9917f95aa5518294 (patch)
tree0148d35ff691bfa2b8d050ab473f7dfd98de23e5 /dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild
parentgnome-extra/cinnamon: Stabilize 6.0.4 amd64, #932975 (diff)
downloadgentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.tar.gz
gentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.tar.bz2
gentoo-8630ff7219b315f4a48bb3db9917f95aa5518294.zip
dev-vcs/python-gitlab: add 4.6.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild')
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild
new file mode 100644
index 000000000000..4da36920b512
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-4.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+MY_PN="${PN/-/_}"
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ inherit pypi
+ SRC_URI="$(pypi_sdist_url) -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+
+BDEPEND="test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ >=dev-python/pytest-console-scripts-1.3.1[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.2[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND=">=dev-python/requests-2.32.2[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-1.0.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}