summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/notify-webhook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/notify-webhook')
-rw-r--r--dev-vcs/notify-webhook/Manifest3
-rw-r--r--dev-vcs/notify-webhook/metadata.xml17
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-20140805.ebuild27
-rw-r--r--dev-vcs/notify-webhook/notify-webhook-20150308.ebuild57
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-vcs/notify-webhook/Manifest b/dev-vcs/notify-webhook/Manifest
new file mode 100644
index 000000000000..f02465c442bc
--- /dev/null
+++ b/dev-vcs/notify-webhook/Manifest
@@ -0,0 +1,3 @@
+DIST notify-webhook-20140805.tar.gz 15078 SHA256 479d71c7ab9ba772a0b621638e80a14cbe6f34e8fbe851d8db93b118d4567e3f SHA512 8e10994ad26d6de86e7930a2299a8701bed0f04299f2ca14b070f00543368015628b89fd4cbf351f3e42e85cf98e7465dd94517243d1beb71b645d91a637e6d2 WHIRLPOOL 533e2118941edc2f9db4412477a76332fe27475ebc882eb8f567d39a846bf04c95cc693230ae32bc1c10bf24301117b7d6e04c08e45e0fe7cf181fe454504a4b
+DIST notify-webhook-20150308-1ff3985...BCLibCoop:ee038b5.patch 8581 SHA256 c6167fd81e88fcb8de6c37bb2c5259f1c09e6e3a7f0b61d6b58f5f5e478e585c SHA512 c72b03cbea34884c089968e67b61e654a9d365e6b2a338363b6405ab1950aaa5a1c4f8ece73181003571a88f1983458c2e9194d6b26aa103c95c1ceed8e0dd4c WHIRLPOOL 3f4be9d58f5d1a4dff2a7978d067afb0e8fb739b6836709964dec17cc386890eb1d97b0652323acaefc7ca5bc5ae25c46f1f222323d471529e92a5640541bcae
+DIST notify-webhook-20150308.tar.gz 16347 SHA256 cb9d2687eea5ab4f32f6fbc9bdb05a24c8b7755193b312a574172f6aaaca857e SHA512 7a82418d16e6cfd58b9bccaf1700c5a9258601a45a823f1b8307ee3b3c6e90ad52424421836468e34b400b07100a291fd514450a2e1b3c2d1c8dff99ee409557 WHIRLPOOL 523578237483d74d2bd4fa9f4f87277b9103c67c415fbb383629211ea91403fc11debfed70fa94069e9bd8e87a1c9e799929aa1c376244e1a2dde656609a10d8
diff --git a/dev-vcs/notify-webhook/metadata.xml b/dev-vcs/notify-webhook/metadata.xml
new file mode 100644
index 000000000000..4ff0a821841e
--- /dev/null
+++ b/dev-vcs/notify-webhook/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ notify-webhook is a git post-receive hook script that posts JSON data to a
+ webhook capable server.
+
+ This implements the GitHub Web hooks API as closely as possible. It allows
+ arbitrary git repositories to use webhook capable services.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">metajack/notify-webhook</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-vcs/notify-webhook/notify-webhook-20140805.ebuild b/dev-vcs/notify-webhook/notify-webhook-20140805.ebuild
new file mode 100644
index 000000000000..a909d4780d58
--- /dev/null
+++ b/dev-vcs/notify-webhook/notify-webhook-20140805.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="Git post-receive web hook notifier in Python."
+HOMEPAGE="https://github.com/metajack/notify-webhook"
+COMMIT='c571160f155122446e97bb01c1150b4d14ea69d6'
+SRC_URI="https://github.com/metajack/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/simplejson"
+RDEPEND="${DEPEND}"
+
+MY_P="${PN}-${COMMIT}"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dodoc *markdown
+ exeinto /usr/libexec/githook/$PN/
+ doexe notify-webhook.py
+}
diff --git a/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild b/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild
new file mode 100644
index 000000000000..9262564d7192
--- /dev/null
+++ b/dev-vcs/notify-webhook/notify-webhook-20150308.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Git post-receive web hook notifier in Python."
+HOMEPAGE="https://github.com/metajack/notify-webhook"
+COMMIT='1ff39853e59bb0ee37c4783da8dcf3ea14cef53f'
+PATCH_COMMIT='BCLibCoop:ee038b53a48e70d9e69c86386c39b7f24736d07e'
+PATCH_DELTA="${COMMIT:0:7}...${PATCH_COMMIT:0:17}"
+PATCH_NAME="${P}-${PATCH_DELTA}.patch"
+SRC_URI="https://github.com/metajack/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz
+ https://github.com/metajack/notify-webhook/compare/${PATCH_DELTA}.patch -> ${PATCH_NAME}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson"
+DEPEND="${RDEPEND}
+ dev-util/patchutils"
+
+MY_P="${PN}-${COMMIT}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+# Yes, this is some creative patch mangling, to avoid a manually created
+# distfile. epatch's dryrun fails on a sequence of changes that depend on each
+# other, so we can clean up the patch to actually pass that check.
+src_prepare() {
+ cd "${T}"
+ cp "${DISTDIR}/${PATCH_NAME}" diff
+ p="newdiff"
+ >$p # Make an empty file to work in
+ splitdiff -a -p 1 diff # split out the patches
+ # combine them to a single patch
+ for f in diff.part*.patch ; do
+ combinediff -p 1 $p $f >$p.new && mv $p.new $p
+ done
+
+ # Now apply it, and dry-run will pass too!
+ cd "${S}"
+ EPATCH_OPTS="-p1" epatch "${T}"/newdiff
+}
+
+src_install() {
+ dodoc *markdown
+ exeinto /usr/libexec/githook/$PN/
+ doexe notify-webhook.py
+}