summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenning Schild <henning@hennsch.de>2018-10-23 17:47:48 +0200
committerFabian Groffen <grobian@gentoo.org>2018-10-27 09:51:21 +0200
commit32c09e12b2dc25a828272ea513ea4763e91c861c (patch)
tree1c0d12eaecb0a2e49a30faa586623cec75bbb86f /dev-vcs/hg-git/hg-git-0.8.12.ebuild
parentdev-python/simpleeval: Version bumps, remove old and migrate to EAPI 7 (diff)
downloadgentoo-32c09e12b2dc25a828272ea513ea4763e91c861c.tar.gz
gentoo-32c09e12b2dc25a828272ea513ea4763e91c861c.tar.bz2
gentoo-32c09e12b2dc25a828272ea513ea4763e91c861c.zip
dev-vcs/hg-git: version bump
Closes: https://github.com/gentoo/gentoo/pull/10206 Signed-off-by: Henning Schild <henning@hennsch.de> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.12.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.12.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.12.ebuild b/dev-vcs/hg-git/hg-git-0.8.12.ebuild
new file mode 100644
index 000000000000..241771d68ef9
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.12.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.org/project/hg-git/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"