summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-10-30 23:08:14 +0800
committerYixun Lan <dlan@gentoo.org>2024-10-30 23:25:42 +0800
commitb43c01339ec66dad65eea8a762f80eb1204d2086 (patch)
tree6c3c7805bf42efbf10421184780e6456f5367497 /dev-vcs/git-pw
parentdev-python/littleutils: Stabilize 0.2.4 hppa, #936711 (diff)
downloadgentoo-b43c01339ec66dad65eea8a762f80eb1204d2086.tar.gz
gentoo-b43c01339ec66dad65eea8a762f80eb1204d2086.tar.bz2
gentoo-b43c01339ec66dad65eea8a762f80eb1204d2086.zip
dev-vcs/git-pw: add 2.7.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.7.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index 6da47180f79d..8735bccd2e98 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1 +1,2 @@
DIST git-pw-2.6.0.tar.gz 35628 BLAKE2B 6f6b5200776eb88c9ab4fcb5149b2e95f90a5d8dcd7bb18b07f326454e8a397266976a8f7f6b635857ebf3da876f9a0c75cd195d731406ef89ef45fe21672ef1 SHA512 b99efa89a5efcf34bd53b0fd691bb9c86f7585f352faab99a795f0902801c95310a7ea1414f8eb0bfac73f8d6af9b4cc7897d7d33cbeb4f3a5faedd35e62af4f
+DIST git-pw-2.7.0.tar.gz 35676 BLAKE2B d02afc06381eb402693024c10f9e8a2bb7b2e1758da8afa7b9a10bedaeb4cb3248ce5de6af0443ca791204f00e366734323cc682a42aed10e5c34abd5becd862 SHA512 a3b345b3e7f13ea5facfd48a9a1c5ba1d6281757afb97bd3fab6a106ad3f5450a3e57d8e836486f4401d56d3123ce4a0592f2419f43ecc99ba2690a84e829a8f
diff --git a/dev-vcs/git-pw/git-pw-2.7.0.ebuild b/dev-vcs/git-pw/git-pw-2.7.0.ebuild
new file mode 100644
index 000000000000..bab1464ff331
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pbr
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}