summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-27 21:01:31 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-27 21:25:07 +0200
commit051f290a7dc6b6386c99ced53bf306dde799260b (patch)
treea061d2a885e67ae7a30a4b0d228e34a8295c1407 /dev-util
parentdev-util/pkgcheck: drop 0.10.18 (diff)
downloadgentoo-051f290a7dc6b6386c99ced53bf306dde799260b.tar.gz
gentoo-051f290a7dc6b6386c99ced53bf306dde799260b.tar.bz2
gentoo-051f290a7dc6b6386c99ced53bf306dde799260b.zip
dev-util/pkgdev: drop 0.2.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgdev/Manifest1
-rw-r--r--dev-util/pkgdev/pkgdev-0.2.3.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/dev-util/pkgdev/Manifest b/dev-util/pkgdev/Manifest
index c379f30e1e06..d5b1085df7b5 100644
--- a/dev-util/pkgdev/Manifest
+++ b/dev-util/pkgdev/Manifest
@@ -1,2 +1 @@
-DIST pkgdev-0.2.3.tar.gz 67292 BLAKE2B 8e4195c1094200836e23f97ed8ddf44659dcbe123180b253bf961fc08f2534d3573c7194302b3dbe866b45a548e63951ef63d4fce77c4d0903c34a0f4ece9c0b SHA512 ea09483fff8d64ed2a53ab3435bf01be172f1ef6fcbcfa5eac2f19104fdd20cd57f045f578db896c92689f4e6e36acfa4ae4feb28424b5566041fc0e1d5ccb05
DIST pkgdev-0.2.4.tar.gz 64156 BLAKE2B 321e14b246a97236142a862968bfc127f3215314ef173dc0d610ca867d00a0db067def7810083b11bf6aea1e36202e6c91d7c63d74aa2b85fb17ec476cba1f7c SHA512 0390e130abda2f8eea1d3dd029d31d9381f2543ca98f547b91716ce383791c3760bd89bb276b5b15eaaa165be339c8147d26e93ba81d5be4c8a4cbede6a31caf
diff --git a/dev-util/pkgdev/pkgdev-0.2.3.ebuild b/dev-util/pkgdev/pkgdev-0.2.3.ebuild
deleted file mode 100644
index dbbf9bf39eed..000000000000
--- a/dev-util/pkgdev/pkgdev-0.2.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/pkgcore/pkgdev.git
- https://github.com/pkgcore/pkgdev.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~x64-macos"
-fi
-
-DESCRIPTION="Collection of tools for Gentoo development"
-HOMEPAGE="https://github.com/pkgcore/pkgdev"
-
-LICENSE="BSD MIT"
-SLOT="0"
-IUSE="doc"
-
-if [[ ${PV} == *9999 ]] ; then
- # https://github.com/pkgcore/pkgdev/blob/main/requirements/dev.txt
- RDEPEND="
- ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- ~dev-util/pkgcheck-9999[${PYTHON_USEDEP}]
- ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]
- "
-else
- # https://github.com/pkgcore/pkgdev/blob/main/requirements/install.txt
- RDEPEND="
- >=dev-python/snakeoil-0.10.1[${PYTHON_USEDEP}]
- >=dev-util/pkgcheck-0.10.16[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.12.16[${PYTHON_USEDEP}]
- "
-fi
-
-# Uses pytest but we want to use the setup.py runner to get generated modules
-BDEPEND+="test? ( dev-python/pytest )"
-RDEPEND+="dev-vcs/git"
-
-distutils_enable_sphinx doc
-distutils_enable_tests setup.py
-
-PATCHES=(
- "${FILESDIR}/pkgdev-0.2.3-docs-path.patch"
-)
-
-python_compile_all() {
- if use doc; then
- "${EPYTHON}" setup.py build_man -f || die
- fi
-
- # HTML pages only
- sphinx_compile_all
-}
-
-python_install_all() {
- # If USE=doc, there'll be newly generated docs which we install instead.
- if use doc; then
- doman build/sphinx/man/*
- elif [[ ${PV} != *9999 ]]; then
- doman man/*.[0-8]
- fi
-
- distutils-r1_python_install_all
-}