summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-01-04 11:34:20 +0100
committerPacho Ramos <pacho@gentoo.org>2018-01-04 11:37:20 +0100
commit158f19e4ea24315601e245376031c7aa3edaa2f7 (patch)
tree8fea529668a265ff7c028055e0989071581f1ef7 /dev-util/trinity
parentwww-apps/nextcloud: does not work with PHP 7.2 (diff)
downloadgentoo-158f19e4ea24315601e245376031c7aa3edaa2f7.tar.gz
gentoo-158f19e4ea24315601e245376031c7aa3edaa2f7.tar.bz2
gentoo-158f19e4ea24315601e245376031c7aa3edaa2f7.zip
dev-util/trinity: Version bump
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util/trinity')
-rw-r--r--dev-util/trinity/Manifest1
-rw-r--r--dev-util/trinity/trinity-1.8.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-util/trinity/Manifest b/dev-util/trinity/Manifest
index 5e658d2441ce..8e0ae95bb9f6 100644
--- a/dev-util/trinity/Manifest
+++ b/dev-util/trinity/Manifest
@@ -1 +1,2 @@
DIST trinity-1.7.tar.xz 195488 BLAKE2B a2efd5fa2dd9ae40e943d96b2ae9232e292bb5cd41a350813a137a5910cf308a06d4e0b1be37e2ab8dc6325443101b6d956a593a778d9a7128e086ebbf6f2b61 SHA512 bb702ec79494591e04c74279e39d6dd0c5779f7cb2696c306c94bee3a8aefb524e369674daadf02f70b58dbb19ad5699d2c331bc4c9089046d2214403a95ba87
+DIST trinity-1.8.tar.xz 213984 BLAKE2B 56f664023e2bc3648e941e4a3cb20e450cdcad3556289e201513d1755267eb013da2be035e81c87b3f1d1b0b1e12cb041c6bb345f7a84ee4c5c12f20a8e87f55 SHA512 686076dab2346cf9b5d8a20b14db31f460a352fa72eeadbe005a7423941918f5afef08b4987bb68cbbf4218d0cb620adb85f8036294d8df5ab5262e0031a44e4
diff --git a/dev-util/trinity/trinity-1.8.ebuild b/dev-util/trinity/trinity-1.8.ebuild
new file mode 100644
index 000000000000..1072988366ec
--- /dev/null
+++ b/dev-util/trinity/trinity-1.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A Linux system call fuzz tester"
+HOMEPAGE="http://codemonkey.org.uk/projects/trinity/"
+SRC_URI="http://codemonkey.org.uk/projects/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# We need newer headers to avoid compilation failures in the BPF stuff.
+DEPEND="app-arch/xz-utils
+ >=sys-kernel/linux-headers-4.8
+"
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_compile() {
+ # Enable a verbose (i.e. not quiet) build.
+ emake V=1
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc Documentation/*
+ einstalldocs
+
+ if use examples ; then
+ exeinto "/usr/share/doc/${PF}/scripts"
+ doexe scripts/*
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ fi
+}