summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-02 21:19:05 +0200
committerMart Raudsepp <leio@gentoo.org>2020-03-02 21:19:05 +0200
commit2de6ef5f0375eb9ac7ef795a5185782e7da2b2f9 (patch)
treee86ceb71b093d38e0e335d07831cd273f4486b04 /dev-util/sysprof-capture
parentsys-cluster/rdma-core: keyworded 28.0 for sparc, bug #705802 (diff)
downloadgentoo-2de6ef5f0375eb9ac7ef795a5185782e7da2b2f9.tar.gz
gentoo-2de6ef5f0375eb9ac7ef795a5185782e7da2b2f9.tar.bz2
gentoo-2de6ef5f0375eb9ac7ef795a5185782e7da2b2f9.zip
dev-util/sysprof-capture: Ship org.gnome.Sysprof3.Profiler.xml here
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-util/sysprof-capture')
-rw-r--r--dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild b/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild
new file mode 100644
index 000000000000..7e76591dccd0
--- /dev/null
+++ b/dev-util/sysprof-capture/sysprof-capture-3.34.1-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="sysprof"
+
+inherit gnome.org meson systemd
+
+DESCRIPTION="Static library for sysprof capture data generation"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.61.3:2
+ !=dev-util/sysprof-3.34.1-r0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ # In 3.34.1 -Dlibsysprof=false still installs various data files related with it;
+ # some of these seem fixed by 3.36
+ sed -i -e '/subdir.*data/d' meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Denable_gtk=false
+ -Dlibsysprof=false
+ -Dwith_sysprofd=none
+ -Dsystemdunitdir=$(systemd_get_systemunitdir)
+ # -Ddebugdir
+ -Dhelp=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ # In 3.36 these shouldn't be needed with with_sysprofd=none
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof2.xml || die
+ rm "${ED}"/usr/share/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml || die
+}