summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/sysdig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/sysdig')
-rw-r--r--dev-util/sysdig/Manifest2
-rw-r--r--dev-util/sysdig/metadata.xml13
-rw-r--r--dev-util/sysdig/sysdig-0.1.92.ebuild85
-rw-r--r--dev-util/sysdig/sysdig-0.1.98.ebuild85
4 files changed, 185 insertions, 0 deletions
diff --git a/dev-util/sysdig/Manifest b/dev-util/sysdig/Manifest
new file mode 100644
index 000000000000..b042b53a4712
--- /dev/null
+++ b/dev-util/sysdig/Manifest
@@ -0,0 +1,2 @@
+DIST sysdig-0.1.92.tar.xz 244728 SHA256 794ae6cef6ab8dae029979f5985b72c15f209e927518a3881e8a7624d77d5132 SHA512 661af8eece353ba0b0ea518496da89f4525f767c2797ff9f9e5caf670b6b3e7fa0c5cb14c3852971f563b665b42105a143d458a041b270d7107a403b2ec98b11 WHIRLPOOL bb47d717bcb3c5c948f4344a56e45996cfe275a48ea19f0fa12c2fce91f81fad317c9b5c05812e9c2aaf02240b597fb85f60a5ad3ee391a1a825de62a7eab57c
+DIST sysdig-0.1.98.tar.xz 263328 SHA256 5d60896ad2997f3dcf5d7252a53f5f7808ded11bd7c63f3a8c2aaaa1421f018f SHA512 8e4ab622fd0d69567e63054df256bfddda5765e2cf4d89490cd871625e4bb16d3d25ecbf0965f00e312d03ef3044615a7fd94d2f704b1a833ae1da9e2f66f33a WHIRLPOOL a96f8e8635d03351e4f42e8b3959c890a63a1232df5c9cc03f9359e18a926e23561e4f4fb10986285ff757e3ee47305a7fde01905541984e5582ba740962db70
diff --git a/dev-util/sysdig/metadata.xml b/dev-util/sysdig/metadata.xml
new file mode 100644
index 000000000000..33c7008e71d7
--- /dev/null
+++ b/dev-util/sysdig/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name='modules'>Build kernel modules needed for tracing local
+ events. Disable this only if you intend to use sysdig purely
+ to work with dumpfiles.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-util/sysdig/sysdig-0.1.92.ebuild b/dev-util/sysdig/sysdig-0.1.92.ebuild
new file mode 100644
index 000000000000..ba9d6addd059
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.1.92.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod bash-completion-r1 cmake-utils
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="http://www.sysdig.org/"
+# mirrored from https://github.com/draios/sysdig/archive/${PV}.tar.gz
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+modules"
+
+RDEPEND="dev-lang/luajit:2=
+ dev-libs/jsoncpp:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/os-headers"
+
+# needed for the kernel module
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS TRACEPOINTS"
+
+pkg_pretend() {
+ use modules && linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ use modules && linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # unbundle the deps
+ -DUSE_BUNDLED_LUAJIT=OFF
+ -DLUAJIT_PREFIX="${EPREFIX}"/usr
+ -DLUAJIT_INCLUDE="${EPREFIX}"/usr/include/luajit-2.0
+ -DUSE_BUNDLED_JSONCPP=OFF
+ -DJSONCPP_PREFIX="${EPREFIX}"/usr
+ -DJSONCPP_INCLUDE="${EPREFIX}"/usr/include/jsoncpp
+ -DUSE_BUNDLED_ZLIB=OFF
+ -DZLIB_PREFIX="${EPREFIX}"/usr
+ )
+
+ cmake-utils_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver:)"
+ BUILD_TARGETS="driver"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use modules && linux-mod_src_install
+
+ # remove sources
+ rm -r "${ED%/}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED%/}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED%/}"/usr/etc || die
+}
diff --git a/dev-util/sysdig/sysdig-0.1.98.ebuild b/dev-util/sysdig/sysdig-0.1.98.ebuild
new file mode 100644
index 000000000000..0e5ae122f56b
--- /dev/null
+++ b/dev-util/sysdig/sysdig-0.1.98.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-mod bash-completion-r1 cmake-utils
+
+DESCRIPTION="A system exploration and troubleshooting tool"
+HOMEPAGE="http://www.sysdig.org/"
+# mirrored from https://github.com/draios/sysdig/archive/${PV}.tar.gz
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+modules"
+
+RDEPEND="dev-lang/luajit:2=
+ >=dev-libs/jsoncpp-0.6_pre:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/os-headers"
+
+# needed for the kernel module
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS TRACEPOINTS"
+
+pkg_pretend() {
+ use modules && linux-mod_pkg_setup
+}
+
+pkg_setup() {
+ use modules && linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's:-ggdb::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod for that
+ -DBUILD_DRIVER=OFF
+ # libscap examples are not installed or really useful
+ -DBUILD_LIBSCAP_EXAMPLES=OFF
+
+ # unbundle the deps
+ -DUSE_BUNDLED_LUAJIT=OFF
+ -DLUAJIT_PREFIX="${EPREFIX}"/usr
+ -DLUAJIT_INCLUDE="${EPREFIX}"/usr/include/luajit-2.0
+ -DUSE_BUNDLED_JSONCPP=OFF
+ -DJSONCPP_PREFIX="${EPREFIX}"/usr
+ -DJSONCPP_INCLUDE="${EPREFIX}"/usr/include/jsoncpp
+ -DUSE_BUNDLED_ZLIB=OFF
+ -DZLIB_PREFIX="${EPREFIX}"/usr
+ )
+
+ cmake-utils_src_configure
+
+ # setup linux-mod ugliness
+ MODULE_NAMES="sysdig-probe(extra:${BUILD_DIR}/driver:)"
+ BUILD_TARGETS="driver"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ use modules && linux-mod_src_install
+
+ # remove sources
+ rm -r "${ED%/}"/usr/src || die
+
+ # move bashcomp to the proper location
+ dobashcomp "${ED%/}"/usr/etc/bash_completion.d/sysdig || die
+ rm -r "${ED%/}"/usr/etc || die
+}