summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-03-24 16:52:53 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-25 19:27:20 +0200
commit5841ca2f526067efc8c7b0a8b76e46b4e2593b25 (patch)
treecc52f652ed934e8955e2ca2a269b5315b8e49d29 /dev-util/statifier
parentsys-apps/portage-mgorny: Bump to 2.3.24.3 (diff)
downloadgentoo-5841ca2f526067efc8c7b0a8b76e46b4e2593b25.tar.gz
gentoo-5841ca2f526067efc8c7b0a8b76e46b4e2593b25.tar.bz2
gentoo-5841ca2f526067efc8c7b0a8b76e46b4e2593b25.zip
dev-util/statifier: Don't compile 32-bit on amd64 no-multilib profile
Closes: https://bugs.gentoo.org/651260 Closes: https://github.com/gentoo/gentoo/pull/7571
Diffstat (limited to 'dev-util/statifier')
-rw-r--r--dev-util/statifier/statifier-1.7.4.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-util/statifier/statifier-1.7.4.ebuild b/dev-util/statifier/statifier-1.7.4.ebuild
index 2e2867cd1b96..a90f4825f90a 100644
--- a/dev-util/statifier/statifier-1.7.4.ebuild
+++ b/dev-util/statifier/statifier-1.7.4.ebuild
@@ -3,6 +3,10 @@
EAPI="6"
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build
+
DESCRIPTION="Statifier is a tool for creating portable, self-containing Linux executables"
HOMEPAGE="http://statifier.sourceforge.net"
SRC_URI="https://sourceforge.net/projects/${PN}/files/${PN}/${PV}/${P}.tar.gz"
@@ -20,6 +24,11 @@ src_prepare() {
# Respect users CFLAGS and LDFLAGS
sed -i -e 's/-Wall -O2/$(CFLAGS) $(LDFLAGS)/g' src/Makefile || die
+ # Don't compile 32-bit on amd64 no-multilib profile
+ if ! use abi_x86_32; then
+ sed -i -e 's/ELF32 .*/ELF32 := no/g' configs/config.x86_64 || die
+ fi
+
# Apply user patches
eapply_user
}