summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /dev-util/sccache
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-util/sccache')
-rw-r--r--dev-util/sccache/sccache-0.5.4-r2.ebuild (renamed from dev-util/sccache/sccache-0.5.4-r1.ebuild)10
-rw-r--r--dev-util/sccache/sccache-9999.ebuild1
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/sccache/sccache-0.5.4-r1.ebuild b/dev-util/sccache/sccache-0.5.4-r2.ebuild
index 97207cbb5aeb..cb475537b793 100644
--- a/dev-util/sccache/sccache-0.5.4-r1.ebuild
+++ b/dev-util/sccache/sccache-0.5.4-r2.ebuild
@@ -387,6 +387,9 @@ CRATES="
zstd@0.12.3+zstd.1.5.2
"
+# https://github.com/rust-lang/rust/issues/113152#issuecomment-1612578376
+RUST_MAX_VER="1.71.1"
+
inherit cargo optfeature systemd
DESCRIPTION="ccache/distcc like tool with support for rust and cloud storage"
@@ -416,7 +419,6 @@ REQUIRED_USE="s3? ( simple-s3 )"
BDEPEND="
virtual/pkgconfig
- >=virtual/rust-1.65
"
DEPEND="
app-arch/zstd
@@ -431,6 +433,12 @@ RDEPEND="
QA_FLAGS_IGNORED="usr/bin/sccache*"
+pkg_setup() {
+ rust_pkg_setup
+ # proc_macro_span_shrink is unstable
+ export RUSTC_BOOTSTRAP=1
+}
+
src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
diff --git a/dev-util/sccache/sccache-9999.ebuild b/dev-util/sccache/sccache-9999.ebuild
index ebb46ec79d8d..575eaa6011e4 100644
--- a/dev-util/sccache/sccache-9999.ebuild
+++ b/dev-util/sccache/sccache-9999.ebuild
@@ -37,7 +37,6 @@ REQUIRED_USE="s3? ( simple-s3 )"
BDEPEND="
virtual/pkgconfig
- >=virtual/rust-1.65
"
DEPEND="
app-arch/zstd