summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/scala-ide
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/scala-ide')
-rw-r--r--dev-util/scala-ide/Manifest2
-rw-r--r--dev-util/scala-ide/metadata.xml8
-rw-r--r--dev-util/scala-ide/scala-ide-4.1.0.ebuild49
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/scala-ide/Manifest b/dev-util/scala-ide/Manifest
new file mode 100644
index 000000000000..f5a6019d6734
--- /dev/null
+++ b/dev-util/scala-ide/Manifest
@@ -0,0 +1,2 @@
+DIST scala-SDK-4.1.0-vfinal-2.11-linux.gtk.x86.tar.gz 232347349 SHA256 1d7054b49195b598d469a2d56971f67aa219c6043cb8209f8c8608160c4df7ad SHA512 f3d8bff300ee772e07f9c9287c37428d5ddf50bd750dcc86b6a28d9ad5a0b891fa8ce810599e754ac06bf48786a9c58b981055c29976c37b2c530466591d171a WHIRLPOOL f584d8d6e129f5464f9eb44ab7137e230dc0b701e07d3569a7975e35a5ecc2a4f6b81e085486f36867b00a9715e1e25b5cd29294c638abe195f4a60677aa61f9
+DIST scala-SDK-4.1.0-vfinal-2.11-linux.gtk.x86_64.tar.gz 232491001 SHA256 d3e9efe1176d979dc0fe2a9457f70068b5a3fd23635a07bcd5639e2345897aca SHA512 d5b8fe3cb3d6623e2f29e0ad5d279b363143c9b392ea5d91092ecb9de765828ac0c50c74ff879f7c825099b22a833ad3acbb0c2cfcd51c769ee19082905b63eb WHIRLPOOL 8007d41e9695c6ae5c3094906ebc6fba263d8d005f6763ce70eb4398db266ea1aff64bc4bc24bc216d0e869e839a92298bb3f85f8149608dd2986d36a3863def
diff --git a/dev-util/scala-ide/metadata.xml b/dev-util/scala-ide/metadata.xml
new file mode 100644
index 000000000000..68b30527c024
--- /dev/null
+++ b/dev-util/scala-ide/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/scala-ide/scala-ide-4.1.0.ebuild b/dev-util/scala-ide/scala-ide-4.1.0.ebuild
new file mode 100644
index 000000000000..e5cbe8d3bae6
--- /dev/null
+++ b/dev-util/scala-ide/scala-ide-4.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit java-pkg-opt-2
+
+SRC_URI_AMD64="http://downloads.typesafe.com/scalaide-pack/${PV}-vfinal-luna-211-20150525/scala-SDK-${PV}-vfinal-2.11-linux.gtk.x86_64.tar.gz"
+SRC_URI_X86="http://downloads.typesafe.com/scalaide-pack/${PV}-vfinal-luna-211-20150525/scala-SDK-${PV}-vfinal-2.11-linux.gtk.x86.tar.gz"
+
+DESCRIPTION="The Scala IDE"
+HOMEPAGE="http://www.scala-ide.org"
+KEYWORDS="amd64 x86"
+SRC_URI="
+ amd64? ( ${SRC_URI_AMD64} )
+ x86? ( ${SRC_URI_X86} )
+"
+
+SLOT="0"
+LICENSE="BSD"
+
+DEPEND=">=virtual/jdk-1.6
+ || (
+ dev-lang/scala
+ dev-lang/scala-bin
+ )"
+RDEPEND=">=virtual/jre-1.6"
+
+MY_D="/opt"
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/eclipse "${WORKDIR}"/"${P}"
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/"${P}"/eclipse "${WORKDIR}"/"${P}"/"${PN}"
+}
+
+src_install() {
+ cd "${D}" || die
+ dodir "${MY_D}" || die
+ insinto "${MY_D}"
+ doins -r "${WORKDIR}"/"${P}" || die
+ insopts -m 0755
+ insinto "${MY_D}"/"${P}"
+ doins "${WORKDIR}"/"${P}"/"${PN}" || die
+ dosym ${MY_D}/${P}/${PN} /usr/bin/${PN} || die
+}