summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-02 05:16:11 +0100
committerSam James <sam@gentoo.org>2024-06-02 05:57:04 +0100
commitf7cef751785df25f1cc7b05cfbfb9fbb09dc7081 (patch)
tree32c89cb70be8f44f7c472f12db2b6081ac11acf1 /dev-util/rpmdevtools
parentapp-admin/opentofu: add 1.7.1 (diff)
downloadgentoo-f7cef751785df25f1cc7b05cfbfb9fbb09dc7081.tar.gz
gentoo-f7cef751785df25f1cc7b05cfbfb9fbb09dc7081.tar.bz2
gentoo-f7cef751785df25f1cc7b05cfbfb9fbb09dc7081.zip
dev-util/rpmdevtools: add 9.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/rpmdevtools')
-rw-r--r--dev-util/rpmdevtools/Manifest1
-rw-r--r--dev-util/rpmdevtools/rpmdevtools-9.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/rpmdevtools/Manifest b/dev-util/rpmdevtools/Manifest
index 4153db7ba2f0..f08fc347182e 100644
--- a/dev-util/rpmdevtools/Manifest
+++ b/dev-util/rpmdevtools/Manifest
@@ -1 +1,2 @@
DIST rpmdevtools-9.5.tar.xz 96724 BLAKE2B a406581be0286a6cb4b611289820f5a2db4306b731b0963881091e27b04b213c155243aeb95eadb41a27ab7a481bf1464d27d31fb52c6b10c3cedb23c1b22d21 SHA512 d2a110e7557eb149113560d64b3ec1ce75e5ee5ee541de3b4ed88f2bf11ef0248c864383bbffb49f8c32920563704da94004a8f9c099ce3610e6168aabfe440a
+DIST rpmdevtools-9.6.tar.xz 96956 BLAKE2B 8e6e6db9de7424cb2f6d79cbc8511d635c02167d0ef52d4d2b30fc8f2d0cdb9b8b238450d5c79e0edd4cab16205346f6fce93c4e26c8934345056c6ded94d742 SHA512 691fec8944029dbe60cb3eab0200d1201f5aa3dd11cd49e8313ee7c1fe998237217ea9c5ae7b4a70f61f3c998093f23d26266b23f41607ddca3148d5f6b6ae06
diff --git a/dev-util/rpmdevtools/rpmdevtools-9.6.ebuild b/dev-util/rpmdevtools/rpmdevtools-9.6.ebuild
new file mode 100644
index 000000000000..2b96823a8f91
--- /dev/null
+++ b/dev-util/rpmdevtools/rpmdevtools-9.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit python-single-r1
+
+DESCRIPTION="Collection of rpm packaging related utilities"
+HOMEPAGE="https://pagure.io/rpmdevtools"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emacs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
+ dev-lang/perl:*
+ $(python_gen_cond_dep '
+ dev-python/progressbar2[${PYTHON_USEDEP}]
+ dev-python/requests_download[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="
+ ${DEPEND}
+ net-misc/curl
+ emacs? ( app-emacs/rpm-spec-mode )
+"
+BDEPEND="sys-apps/help2man"
+
+src_prepare() {
+ default
+ python_fix_shebang rpmdev-{bumpspec,checksig,rmdevelrpms.py,sort,spectool,vercmp}
+}