summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-09-04 22:22:22 +0300
committerSam James <sam@gentoo.org>2023-03-11 16:25:16 +0000
commit65f5eec96be908fc0fc6ff1a4811242d049b8ef6 (patch)
tree43629315b448c1e8f1e6a148fa111129006ff5a0 /dev-util/rocminfo/rocminfo-5.4.3.ebuild
parentmedia-libs/exiftool: fix copyright (diff)
downloadgentoo-65f5eec96be908fc0fc6ff1a4811242d049b8ef6.tar.gz
gentoo-65f5eec96be908fc0fc6ff1a4811242d049b8ef6.tar.bz2
gentoo-65f5eec96be908fc0fc6ff1a4811242d049b8ef6.zip
dev-util/rocminfo: enable release build
The rocminfo CMake file uses a custom variable named ROCRTST_BLD_TYPE to set CMAKE_BUILD_TYPE. When not set, this defaults to Debug, which adds -O0 to CXXFLAGS. This overrides the optimization flags in CXXFLAGS in make.conf. When the CXXFLAGS in make.conf contain _FORTIFY_SOURCE, this breaks compilation with the following error: /usr/include/features.h:412:4: error: #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp] 412 | # warning _FORTIFY_SOURCE requires compiling with optimization (-O) | ^~~~~~~ Fix this by setting the ROCRTST_BLD_TYPE variable to Release in mycmakeargs. Closes: https://bugs.gentoo.org/887583 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Closes: https://github.com/gentoo/gentoo/pull/27145 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo/rocminfo-5.4.3.ebuild')
-rw-r--r--dev-util/rocminfo/rocminfo-5.4.3.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-util/rocminfo/rocminfo-5.4.3.ebuild b/dev-util/rocminfo/rocminfo-5.4.3.ebuild
index 34df3ab7b44e..15e50f8d07fa 100644
--- a/dev-util/rocminfo/rocminfo-5.4.3.ebuild
+++ b/dev-util/rocminfo/rocminfo-5.4.3.ebuild
@@ -29,3 +29,8 @@ src_prepare() {
sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
cmake_src_prepare
}
+
+src_configure() {
+ local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
+ cmake_src_configure
+}