summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Janda <felix.janda@posteo.de>2016-09-25 10:44:01 -0400
committerDavid Seifert <soap@gentoo.org>2016-10-22 11:27:04 +0200
commit526fb15e0d3122564e0211c466cac4e9e35ef687 (patch)
tree9b377052f8627135a02dc907d61fe441655e2607 /dev-util/pkgconf/pkgconf-9999.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {3.2.83,3.16.38} - remo... (diff)
downloadgentoo-526fb15e0d3122564e0211c466cac4e9e35ef687.tar.gz
gentoo-526fb15e0d3122564e0211c466cac4e9e35ef687.tar.bz2
gentoo-526fb15e0d3122564e0211c466cac4e9e35ef687.zip
dev-util/pkgconf: bump to version 1.0.1
- fixes test failures (bug #562220) - migrate to EAPI6 and git-r3 Gentoo-Bug: https://bugs.gentoo.org/562220 Closes: https://github.com/gentoo/gentoo/pull/2410 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf/pkgconf-9999.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild30
1 files changed, 18 insertions, 12 deletions
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index aed82b201943..eff8a40f5340 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,18 +1,21 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
- inherit autotools git-2 multilib-minimal
+ EGIT_REPO_URI=( {https,git}://github.com/pkgconf/${PN}.git )
+ inherit autotools git-r3
else
- inherit autotools multilib-minimal vcs-snapshot
- SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
+ SRC_URI="https://github.com/pkgconf/pkgconf/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh
+ ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux
+ ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
fi
+inherit multilib-minimal
+
DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
HOMEPAGE="https://github.com/pkgconf/pkgconf"
@@ -33,8 +36,9 @@ MULTILIB_CHOST_TOOLS=(
)
src_prepare() {
- [[ -e configure ]] || eautoreconf
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
if use pkg-config; then
MULTILIB_CHOST_TOOLS+=(
/usr/bin/pkg-config
@@ -49,8 +53,10 @@ multilib_src_configure() {
multilib_src_install() {
default
- use pkg-config \
- && dosym pkgconf /usr/bin/pkg-config \
- || rm "${ED}"/usr/share/aclocal/pkg.m4 \
- || die
+
+ if use pkg-config; then
+ dosym pkgconf /usr/bin/pkg-config
+ else
+ rm "${ED%/}"/usr/share/aclocal/pkg.m4 || die
+ fi
}