summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-01-07 18:46:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2018-01-07 19:39:45 +0000
commit67ec9ae5fc78bc1ee31fa38caa92bb89bcf33c68 (patch)
treec93956242966b89a1bd61a5d51a0169bf18a8653 /dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild
parentdev-util/w32api: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only (diff)
downloadgentoo-67ec9ae5fc78bc1ee31fa38caa92bb89bcf33c68.tar.gz
gentoo-67ec9ae5fc78bc1ee31fa38caa92bb89bcf33c68.tar.bz2
gentoo-67ec9ae5fc78bc1ee31fa38caa92bb89bcf33c68.zip
dev-util/mingw64-runtime: Migrate CROSSCOMPILE_OPTS=headers-only -> USE=headers-only
CROSSCOMPILE_OPTS is a USE_EXPAND of a single item: headers-only. Convert it to a global USE flag instead. Mechanical ebuild rename done as: $ sed -e 's@crosscompile_opts_headers-only@headers-only@g' \ -i $(git grep -l headers-only) 'headers-only' flag is used by crossdev to bootstrap stage1 compiler before libc is available. crossdev switched to USE=headers-only in =sys-devel/crossdev-20171230. Bug: https://bugs.gentoo.org/642712 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild
index 534091fe6549..25df5eae738c 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-5.0.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -22,7 +22,7 @@ SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v$
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="crosscompile_opts_headers-only idl libraries tools"
+IUSE="headers-only idl libraries tools"
RESTRICT="strip"
S="${WORKDIR}/mingw-w64-v${PV}"
@@ -37,7 +37,7 @@ is_crosscompile() {
[[ ${CHOST} != ${CTARGET} ]]
}
just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+ use headers-only && [[ ${CHOST} != ${CTARGET} ]]
}
crt_with() {
just_headers && echo --without-$1 || echo --with-$1