summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-26 22:06:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-26 22:30:38 +0200
commitbd10ea30b77a28eade20300c9cca89b4d53d2107 (patch)
treec07632bdd9b7370205a4466badce0879b495e92d /dev-util/mdds
parentdev-python/aiohttp: version bump to 2.1.0 (diff)
downloadgentoo-bd10ea30b77a28eade20300c9cca89b4d53d2107.tar.gz
gentoo-bd10ea30b77a28eade20300c9cca89b4d53d2107.tar.bz2
gentoo-bd10ea30b77a28eade20300c9cca89b4d53d2107.zip
dev-util/mdds: 1.2.3 version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-util/mdds')
-rw-r--r--dev-util/mdds/Manifest1
-rw-r--r--dev-util/mdds/files/mdds-1.2.3-buildsystem.patch36
-rw-r--r--dev-util/mdds/mdds-1.2.3.ebuild48
-rw-r--r--dev-util/mdds/mdds-9999.ebuild10
4 files changed, 90 insertions, 5 deletions
diff --git a/dev-util/mdds/Manifest b/dev-util/mdds/Manifest
index 409a9f87dc7e..4fdbfae649d1 100644
--- a/dev-util/mdds/Manifest
+++ b/dev-util/mdds/Manifest
@@ -1 +1,2 @@
DIST mdds-1.2.2.tar.bz2 286185 SHA256 141e730b39110434b02cd844c5ad3442103f7c35f7e9a4d6a9f8af813594cc9d SHA512 552cb1b65c03cd18eb679c95821e47c1151e1b3015043de4b3a7bc14d27734772fa4d80fd90ab48998d0bc75385a3d29c4dd7ce826cf84b012685573c623bf01 WHIRLPOOL f0b24a886ad6b275267603b73a95c3b83ce14808f90daa0e680babec966a52de19349ac0991d76b9279818897f783d1768ece74f5f1be1157fa8bff94e5e8a5a
+DIST mdds-1.2.3.tar.bz2 287079 SHA256 402fec18256f95b89517d54d85f00bce1faa6e517cb3d7c98a720fddd063354f SHA512 e5935fd99a53df124532cfc8e46349b2ef9ca79f5f184ca2da941c9a77e66ee40e11478e520bf9cb62e1bcea4b69deab5088265e1b89fda04417130aab227c3d WHIRLPOOL 88e154f3e1141d09736a8a9d5b4adf3612cea95a82773f59053d8e83f7fec3a0c292f5453df92627f31ac7e12b2f702dc281c959e7f219de91f2a1acc15cc7b4
diff --git a/dev-util/mdds/files/mdds-1.2.3-buildsystem.patch b/dev-util/mdds/files/mdds-1.2.3-buildsystem.patch
new file mode 100644
index 000000000000..89b45d826e04
--- /dev/null
+++ b/dev-util/mdds/files/mdds-1.2.3-buildsystem.patch
@@ -0,0 +1,36 @@
+We want to install (not all of) those files manually.
+
+--- a/Makefile.am 2017-05-24 23:59:15.000000000 +0200
++++ b/Makefile.am 2017-05-26 21:52:01.184258647 +0200
+@@ -4,16 +4,12 @@
+
+ AM_CPPFLAGS = -I$(top_srcdir)/include
+
+-dist_doc_DATA = AUTHORS README.md
+-nodist_doc_DATA = VERSION
+ nodist_pkgconf_DATA = misc/mdds-@API_VERSION@.pc
+
+ DISTCLEANFILES = misc/mdds-@API_VERSION@.pc
+
+ EXTRA_DIST = \
+ autogen.sh \
+- CHANGELOG \
+- LICENSE \
+ doc/conf.py \
+ doc/doxygen.conf \
+ doc/flat_segment_tree.rst \
+@@ -151,14 +147,6 @@
+ trie_map_test_mem.mem
+ endif
+
+-install-data-local:
+- $(MKDIR_P) $(DESTDIR)$(docdir)
+- $(INSTALL_DATA) $(top_srcdir)/LICENSE $(DESTDIR)$(docdir)/COPYING
+- $(INSTALL_DATA) $(top_srcdir)/CHANGELOG $(DESTDIR)$(docdir)/NEWS
+-
+-uninstall-local:
+- rm -f $(DESTDIR)$(docdir)/COPYING $(DESTDIR)$(docdir)/NEWS
+-
+ if BUILD_DOCS
+ html-local:
+ (cd doc && $(DOXYGEN) doxygen.conf)
diff --git a/dev-util/mdds/mdds-1.2.3.ebuild b/dev-util/mdds/mdds-1.2.3.ebuild
new file mode 100644
index 000000000000..2205550deef2
--- /dev/null
+++ b/dev-util/mdds/mdds-1.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3"
+
+inherit autotools toolchain-funcs ${GITECLASS}
+
+DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
+HOMEPAGE="https://gitlab.com/mdds/mdds"
+[[ ${PV} == 9999 ]] || SRC_URI="http://kohei.us/files/${PN}/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="1/${PV%.*}"
+IUSE="doc valgrind"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ dev-python/sphinx
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-buildsystem.patch" )
+
+src_prepare(){
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc docs) \
+ $(use_enable valgrind memory_tests)
+}
+
+src_compile() { :; }
+
+src_test() {
+ tc-export CXX
+ default
+}
diff --git a/dev-util/mdds/mdds-9999.ebuild b/dev-util/mdds/mdds-9999.ebuild
index cbc8fcb3af6f..e87dc4be509d 100644
--- a/dev-util/mdds/mdds-9999.ebuild
+++ b/dev-util/mdds/mdds-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
EGIT_REPO_URI="https://gitlab.com/mdds/mdds.git"
-[[ ${PV} == 9999 ]] && GITECLASS="git-r3 autotools"
+[[ ${PV} == 9999 ]] && GITECLASS="git-r3"
-inherit toolchain-funcs ${GITECLASS}
+inherit autotools toolchain-funcs ${GITECLASS}
DESCRIPTION="A collection of multi-dimensional data structure and indexing algorithm"
HOMEPAGE="https://gitlab.com/mdds/mdds"
@@ -27,11 +27,11 @@ DEPEND="${RDEPEND}
)
"
-DOCS=() # buildsystem installs docs
+PATCHES=( "${FILESDIR}/${PN}-1.2.3-buildsystem.patch" )
src_prepare(){
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {