summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-10-23 17:36:23 +0800
committerYixun Lan <dlan@gentoo.org>2019-10-23 17:36:23 +0800
commit47220737a1d40755e8dcc231596cb3797d4f7fab (patch)
tree1a9531fda106d3f960154e633faaf0ea0a6d7cf0 /dev-util/lttng-modules/lttng-modules-2.10.12.ebuild
parentnet-analyzer/netselect: Drop flag-o-matic.eclass (diff)
downloadgentoo-47220737a1d40755e8dcc231596cb3797d4f7fab.tar.gz
gentoo-47220737a1d40755e8dcc231596cb3797d4f7fab.tar.bz2
gentoo-47220737a1d40755e8dcc231596cb3797d4f7fab.zip
dev-util/lttng-modules: version bump, 2.10.12
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/lttng-modules/lttng-modules-2.10.12.ebuild')
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.10.12.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/lttng-modules-2.10.12.ebuild b/dev-util/lttng-modules/lttng-modules-2.10.12.ebuild
new file mode 100644
index 000000000000..a3fb417feffc
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.10.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="http://lttng.org"
+SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 27; then
+ eerror "${PN} require Linux kernel >= 2.6.27"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md TODO
+}