summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick H <gerkola@gmail.com>2020-08-27 20:53:12 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-09-29 08:59:01 +0300
commita9a2d89de7dea17e3bca681607889d37a135144d (patch)
tree61bd2212412181c66954bdd8977b2c3a98ae7cbc /dev-util/lcov/lcov-1.15.ebuild
parentmedia-gfx/qiv: remove old 2.3.2-r0 (diff)
downloadgentoo-a9a2d89de7dea17e3bca681607889d37a135144d.tar.gz
gentoo-a9a2d89de7dea17e3bca681607889d37a135144d.tar.bz2
gentoo-a9a2d89de7dea17e3bca681607889d37a135144d.zip
dev-util/lcov: add 1.15
Signed-off-by: Nick Herman <gerkola@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/17284 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/lcov/lcov-1.15.ebuild')
-rw-r--r--dev-util/lcov/lcov-1.15.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/lcov/lcov-1.15.ebuild b/dev-util/lcov/lcov-1.15.ebuild
new file mode 100644
index 000000000000..67bf3e5ce14c
--- /dev/null
+++ b/dev-util/lcov/lcov-1.15.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
+fi
+
+inherit prefix
+
+DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
+HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="png"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/JSON
+ dev-perl/PerlIO-gzip
+ png? ( dev-perl/GD[png] )
+"
+
+src_prepare() {
+ default
+ if use prefix; then
+ hprefixify bin/*.{pl,sh}
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ emake PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
+}