summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/kdbg
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/kdbg')
-rw-r--r--dev-util/kdbg/Manifest2
-rw-r--r--dev-util/kdbg/kdbg-2.5.4.ebuild38
-rw-r--r--dev-util/kdbg/kdbg-2.5.5.ebuild38
-rw-r--r--dev-util/kdbg/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/kdbg/Manifest b/dev-util/kdbg/Manifest
new file mode 100644
index 000000000000..4d019193a353
--- /dev/null
+++ b/dev-util/kdbg/Manifest
@@ -0,0 +1,2 @@
+DIST kdbg-2.5.4.tar.gz 408683 SHA256 82a9ac163311319ae83002b7f250eac02fd4be176d037519adc38e107caaa6e5 SHA512 4855d8aada59dd201b24d8640d597dddef710efccf5caf450e9119bd5a01de5e1d62ccbfecb385f6a5b78fb6d761ead153c963cc882246e742e58db51e4d59ae WHIRLPOOL ecb99ee2a830008e56c8eccf264e2decdc548cb2bc0e06f831dcdfc885c6b3f186abe6c88240b3545c0cc6b79f9e18a9287f033675fcf184affcc0a8e7ec8f13
+DIST kdbg-2.5.5.tar.gz 417327 SHA256 983e4c89258d752f42449e2d257c9e40352b516328132ca5b0b1991b91878879 SHA512 f855063c0ea55a624ced3d6ff52466bc7240e2b79d76b43d73d224348f1b7c179fd1d53391e0e7039a2222659b7d6c3aba9f423f565b073073d636c28cc323f6 WHIRLPOOL 2fc9f7d092e3584216701bee57b11982c0ab4047090de3e43d1136ac5b8dd86e39a12db7f89e6664adf4e477cecdc4217421161c1458b75d5ff65180b8b89108
diff --git a/dev-util/kdbg/kdbg-2.5.4.ebuild b/dev-util/kdbg/kdbg-2.5.4.ebuild
new file mode 100644
index 000000000000..44b5ce76f1c3
--- /dev/null
+++ b/dev-util/kdbg/kdbg-2.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="cs da de es fr hr hu it ja nb nn pl pt ro ru sk sr sv tr zh_CN"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A graphical debugger interface"
+HOMEPAGE="http://www.kdbg.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-devel/gdb"
+DEPEND="${RDEPEND}"
+
+DOCS=( BUGS README ReleaseNotes-${PV} TODO )
+
+src_prepare() {
+ # allow documentation to be handled by eclass
+ mv kdbg/doc . || die
+ sed -i -e '/add_subdirectory(doc)/d' kdbg/CMakeLists.txt || die
+ echo "add_subdirectory ( doc ) " >> CMakeLists.txt || die
+ kde4-base_src_prepare
+}
+
+ssrc_install() {
+ kde4-base_src_install
+
+ # hack since ChangeLog-* is automagically installed by eclass
+ rm -f "${ED}"usr/share/doc/${PF}/ChangeLog-pre*
+}
diff --git a/dev-util/kdbg/kdbg-2.5.5.ebuild b/dev-util/kdbg/kdbg-2.5.5.ebuild
new file mode 100644
index 000000000000..3600f6197fe4
--- /dev/null
+++ b/dev-util/kdbg/kdbg-2.5.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_LINGUAS="cs da de es fr hr hu it ja nb nn pl pt ro ru sk sr sv tr zh_CN"
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="A graphical debugger interface"
+HOMEPAGE="http://www.kdbg.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="sys-devel/gdb"
+DEPEND="${RDEPEND}"
+
+DOCS=( BUGS README ReleaseNotes-${PV} TODO )
+
+src_prepare() {
+ # allow documentation to be handled by eclass
+ mv kdbg/doc . || die
+ sed -i -e '/add_subdirectory(doc)/d' kdbg/CMakeLists.txt || die
+ echo "add_subdirectory ( doc ) " >> CMakeLists.txt || die
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # hack since ChangeLog-* is automagically installed by eclass
+ rm -f "${ED}"usr/share/doc/${PF}/ChangeLog-pre*
+}
diff --git a/dev-util/kdbg/metadata.xml b/dev-util/kdbg/metadata.xml
new file mode 100644
index 000000000000..82cdedc036ae
--- /dev/null
+++ b/dev-util/kdbg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <upstream>
+ <remote-id type="sourceforge">kdbg</remote-id>
+ </upstream>
+</pkgmetadata>