summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-11-25 12:09:33 -0500
committerMatt Turner <mattst88@gentoo.org>2023-11-25 12:31:01 -0500
commit37d429c9efaf3ab8eb7814bdfa65bc4b8cccd7f6 (patch)
tree9b1ba7208a642ffb29587546b852ef2aaea9a282 /dev-util/intel_clc
parentdev-libs/libinput: Drop old versions (diff)
downloadgentoo-37d429c9efaf3ab8eb7814bdfa65bc4b8cccd7f6.tar.gz
gentoo-37d429c9efaf3ab8eb7814bdfa65bc4b8cccd7f6.tar.bz2
gentoo-37d429c9efaf3ab8eb7814bdfa65bc4b8cccd7f6.zip
dev-util/intel_clc: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util/intel_clc')
-rw-r--r--dev-util/intel_clc/Manifest2
-rw-r--r--dev-util/intel_clc/intel_clc-23.3.0_rc3-r1.ebuild115
-rw-r--r--dev-util/intel_clc/intel_clc-23.3.0_rc4.ebuild115
3 files changed, 0 insertions, 232 deletions
diff --git a/dev-util/intel_clc/Manifest b/dev-util/intel_clc/Manifest
index 503c13cf2cee..1322489ee515 100644
--- a/dev-util/intel_clc/Manifest
+++ b/dev-util/intel_clc/Manifest
@@ -1,3 +1 @@
-DIST mesa-23.3.0-rc3.tar.xz 19192936 BLAKE2B a54ac02b99bf00e4dae34938fd37d5314ae0fd9dee4b2f8928119bcc5a6b4e00add8ad61da3569b9993b37014433fb38a66d945e77184d86aaf0cd79e8afb42b SHA512 be70ce2ba0051685e9585944dcfc8c66d33f68827781d6d003a98b4409bd9e28d00eef730e0eded5c1c14a600219411753c14c7e5e34190bbe8b65b5bf28fabd
-DIST mesa-23.3.0-rc4.tar.xz 19214260 BLAKE2B e52912990f31a22a2c3492690331c695d66783ad583bc5e13ebca6c6328b7a679fb7f008f2a5fcd374f98887dfa012fe6daad31fb9a686142376215920418be5 SHA512 4b54131831fd4b73348e282cf1854d8c10f948c1468c1c069c147172a104b44a6253815a8f1487e5ec72c147a78b438286145a4683c18a64550f0405a8197d52
DIST mesa-23.3.0-rc5.tar.xz 19227440 BLAKE2B 844eb3dacc6f579f1a7bff74fc20ec22021ac33dcdd716488487e66e9ef8c6be4a5eaf7260628eec58baa55fd70bfe4a6223e83ea8b163d6e16dd8677af3c7e3 SHA512 f1c2421ab262da422ed9ac5ca08b0e1c41264373e022de9413c65e1e7e8ee929979d1c80741497a0acba1d118665a7f6076e24139be0c9c70f3fe8f5d319c187
diff --git a/dev-util/intel_clc/intel_clc-23.3.0_rc3-r1.ebuild b/dev-util/intel_clc/intel_clc-23.3.0_rc3-r1.ebuild
deleted file mode 100644
index cf18be99437e..000000000000
--- a/dev-util/intel_clc/intel_clc-23.3.0_rc3-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit llvm meson python-any-r1
-
-MY_PV="${PV/_/-}"
-
-DESCRIPTION="intel_clc tool used for building OpenCL C to SPIR-V"
-HOMEPAGE="https://mesa3d.org/"
-
-if [[ ${PV} == 9999 ]]; then
- S="${WORKDIR}/intel_clc-${MY_PV}"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/mesa.git"
- inherit git-r3
-else
- S="${WORKDIR}/mesa-${MY_PV}"
- SRC_URI="https://archive.mesa3d.org/mesa-${MY_PV}.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT SGI-B-2.0"
-SLOT="0"
-IUSE="debug"
-
-RDEPEND="
- dev-libs/libclc
- dev-util/spirv-tools
- >=sys-libs/zlib-1.2.8:=
- x11-libs/libdrm
-"
-DEPEND="${RDEPEND}
- dev-libs/expat
-"
-BDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
- virtual/pkgconfig
-"
-
-# Please keep the LLVM dependency block separate. Since LLVM is slotted,
-# we need to *really* make sure we're not pulling one than more slot
-# simultaneously.
-#
-# How to use it:
-# 1. Specify LLVM_MAX_SLOT (inclusive), e.g. 16.
-# 2. Specify LLVM_MIN_SLOT (inclusive), e.g. 15.
-LLVM_MAX_SLOT="16"
-LLVM_MIN_SLOT="15"
-PER_SLOT_DEPSTR="
- (
- dev-util/spirv-llvm-translator:@SLOT@
- sys-devel/clang:@SLOT@
- sys-devel/llvm:@SLOT@
- )
-"
-LLVM_DEPSTR="
- || (
- $(for ((slot=LLVM_MAX_SLOT; slot>=LLVM_MIN_SLOT; slot--)); do
- echo "${PER_SLOT_DEPSTR//@SLOT@/${slot}}"
- done)
- )
- <sys-devel/clang-$((LLVM_MAX_SLOT + 1)):=
- <sys-devel/llvm-$((LLVM_MAX_SLOT + 1)):=
-"
-RDEPEND="${RDEPEND}
- ${LLVM_DEPSTR}
-"
-unset LLVM_MIN_SLOT {LLVM,PER_SLOT}_DEPSTR
-
-llvm_check_deps() {
- has_version "dev-util/spirv-llvm-translator:${LLVM_SLOT}" &&
- has_version "sys-devel/clang:${LLVM_SLOT}" &&
- has_version "sys-devel/llvm:${LLVM_SLOT}"
-}
-
-python_check_deps() {
- python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
-
- local emesonargs=(
- -Dllvm=enabled
- -Dshared-llvm=enabled
- -Dintel-clc=enabled
-
- -Dgallium-drivers=''
- -Dvulkan-drivers=''
-
- # Set platforms empty to avoid the default "auto" setting. If
- # platforms is empty meson.build will add surfaceless.
- -Dplatforms=''
-
- -Dglx=disabled
- -Dzstd=disabled
-
- --buildtype $(usex debug debug plain)
- -Db_ndebug=$(usex debug false true)
- )
- meson_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/src/intel/compiler/intel_clc
-}
diff --git a/dev-util/intel_clc/intel_clc-23.3.0_rc4.ebuild b/dev-util/intel_clc/intel_clc-23.3.0_rc4.ebuild
deleted file mode 100644
index cf18be99437e..000000000000
--- a/dev-util/intel_clc/intel_clc-23.3.0_rc4.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit llvm meson python-any-r1
-
-MY_PV="${PV/_/-}"
-
-DESCRIPTION="intel_clc tool used for building OpenCL C to SPIR-V"
-HOMEPAGE="https://mesa3d.org/"
-
-if [[ ${PV} == 9999 ]]; then
- S="${WORKDIR}/intel_clc-${MY_PV}"
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mesa/mesa.git"
- inherit git-r3
-else
- S="${WORKDIR}/mesa-${MY_PV}"
- SRC_URI="https://archive.mesa3d.org/mesa-${MY_PV}.tar.xz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="MIT SGI-B-2.0"
-SLOT="0"
-IUSE="debug"
-
-RDEPEND="
- dev-libs/libclc
- dev-util/spirv-tools
- >=sys-libs/zlib-1.2.8:=
- x11-libs/libdrm
-"
-DEPEND="${RDEPEND}
- dev-libs/expat
-"
-BDEPEND="
- ${PYTHON_DEPS}
- $(python_gen_any_dep ">=dev-python/mako-0.8.0[\${PYTHON_USEDEP}]")
- virtual/pkgconfig
-"
-
-# Please keep the LLVM dependency block separate. Since LLVM is slotted,
-# we need to *really* make sure we're not pulling one than more slot
-# simultaneously.
-#
-# How to use it:
-# 1. Specify LLVM_MAX_SLOT (inclusive), e.g. 16.
-# 2. Specify LLVM_MIN_SLOT (inclusive), e.g. 15.
-LLVM_MAX_SLOT="16"
-LLVM_MIN_SLOT="15"
-PER_SLOT_DEPSTR="
- (
- dev-util/spirv-llvm-translator:@SLOT@
- sys-devel/clang:@SLOT@
- sys-devel/llvm:@SLOT@
- )
-"
-LLVM_DEPSTR="
- || (
- $(for ((slot=LLVM_MAX_SLOT; slot>=LLVM_MIN_SLOT; slot--)); do
- echo "${PER_SLOT_DEPSTR//@SLOT@/${slot}}"
- done)
- )
- <sys-devel/clang-$((LLVM_MAX_SLOT + 1)):=
- <sys-devel/llvm-$((LLVM_MAX_SLOT + 1)):=
-"
-RDEPEND="${RDEPEND}
- ${LLVM_DEPSTR}
-"
-unset LLVM_MIN_SLOT {LLVM,PER_SLOT}_DEPSTR
-
-llvm_check_deps() {
- has_version "dev-util/spirv-llvm-translator:${LLVM_SLOT}" &&
- has_version "sys-devel/clang:${LLVM_SLOT}" &&
- has_version "sys-devel/llvm:${LLVM_SLOT}"
-}
-
-python_check_deps() {
- python_has_version -b ">=dev-python/mako-0.8.0[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- PKG_CONFIG_PATH="$(get_llvm_prefix "${LLVM_MAX_SLOT}")/$(get_libdir)/pkgconfig"
-
- local emesonargs=(
- -Dllvm=enabled
- -Dshared-llvm=enabled
- -Dintel-clc=enabled
-
- -Dgallium-drivers=''
- -Dvulkan-drivers=''
-
- # Set platforms empty to avoid the default "auto" setting. If
- # platforms is empty meson.build will add surfaceless.
- -Dplatforms=''
-
- -Dglx=disabled
- -Dzstd=disabled
-
- --buildtype $(usex debug debug plain)
- -Db_ndebug=$(usex debug false true)
- )
- meson_src_configure
-}
-
-src_install() {
- dobin "${BUILD_DIR}"/src/intel/compiler/intel_clc
-}