summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-02 20:13:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-02 20:40:21 +0100
commit164bace0ae36f029e1a2ac2d257c799d12bf5875 (patch)
tree0211b78712024755d0da02597cc1d58bcf3ba78e /dev-util/indent
parentdev-util/kdevelop-php: 5.6.2 version bump (diff)
downloadgentoo-164bace0ae36f029e1a2ac2d257c799d12bf5875.tar.gz
gentoo-164bace0ae36f029e1a2ac2d257c799d12bf5875.tar.bz2
gentoo-164bace0ae36f029e1a2ac2d257c799d12bf5875.zip
dev-util/indent: EAPI-7 bump, swap out eutils with l10n.eclass
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/indent')
-rw-r--r--dev-util/indent/indent-2.2.12.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-util/indent/indent-2.2.12.ebuild b/dev-util/indent/indent-2.2.12.ebuild
index ab0455d550ad..a3c8834d1a88 100644
--- a/dev-util/indent/indent-2.2.12.ebuild
+++ b/dev-util/indent/indent-2.2.12.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils
+EAPI=7
+
+inherit l10n
DESCRIPTION="Indent program source files"
HOMEPAGE="https://www.gnu.org/software/indent/"
@@ -13,9 +14,9 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="nls"
-DEPEND="
- nls? ( sys-devel/gettext )
+BDEPEND="
app-text/texi2html
+ nls? ( sys-devel/gettext )
"
RDEPEND="
nls? ( virtual/libintl )
@@ -23,7 +24,6 @@ RDEPEND="
src_prepare() {
default
-
sed -i -e '/AM_CFLAGS/s:-Werror::g' src/Makefile.{am,in} || die
}
@@ -47,5 +47,5 @@ src_test() {
src_install() {
# htmldir as set in configure is ignored in doc/Makefile*
emake DESTDIR="${D}" htmldir="${EPREFIX}/usr/share/doc/${PF}/html" install
- dodoc AUTHORS NEWS README.md ChangeLog ChangeLog-1990 ChangeLog-1998 ChangeLog-2001
+ dodoc AUTHORS NEWS README.md ChangeLog{,-1990,-1998,-2001}
}