summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-02-19 11:14:46 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-02-22 19:19:56 +0100
commit67b391a0cf56555d78608afea0fdd15b9cddc1dd (patch)
treeb7b6b6cc230226a20c50f5d380d24e55adf68007 /dev-util/glslang
parentmedia-libs/vulkan-loader: update EAPI 7 -> 8, drop obsolete einfo (diff)
downloadgentoo-67b391a0cf56555d78608afea0fdd15b9cddc1dd.tar.gz
gentoo-67b391a0cf56555d78608afea0fdd15b9cddc1dd.tar.bz2
gentoo-67b391a0cf56555d78608afea0fdd15b9cddc1dd.zip
dev-util/glslang: update EAPI 7 -> 8, more skel.ebuild style
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-util/glslang')
-rw-r--r--dev-util/glslang/glslang-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-util/glslang/glslang-9999.ebuild b/dev-util/glslang/glslang-9999.ebuild
index a06a97ac7bde..c00807a5549c 100644
--- a/dev-util/glslang/glslang-9999.ebuild
+++ b/dev-util/glslang/glslang-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
inherit cmake-multilib python-any-r1
@@ -19,16 +19,16 @@ fi
DESCRIPTION="Khronos reference front-end for GLSL and ESSL, and sample SPIR-V generator"
HOMEPAGE="https://www.khronos.org/opengles/sdk/tools/Reference-Compiler/ https://github.com/KhronosGroup/glslang"
-PATCHES=( "${FILESDIR}/${PN}-1.3.236-Install-static-libs.patch" )
-
LICENSE="BSD"
SLOT="0/12"
-BDEPEND="${PYTHON_DEPS}"
-
# Bug 698850
RESTRICT="test"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}/${PN}-1.3.236-Install-static-libs.patch" )
+
multilib_src_configure() {
local mycmakeargs=(
-DENABLE_PCH=OFF