summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-09-24 14:07:07 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-09-24 14:08:46 -0500
commit838168881c7969b0a901180686103807f792974e (patch)
tree11780bc2c8838fc1fab15ab2b27bd0ca7ef9f86d /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 15.3.1 (diff)
downloadgentoo-838168881c7969b0a901180686103807f792974e.tar.gz
gentoo-838168881c7969b0a901180686103807f792974e.tar.bz2
gentoo-838168881c7969b0a901180686103807f792974e.zip
dev-util/gitlab-runner: add 15.4.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.4.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index c65768fa903a..364c847dfed7 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -14,3 +14,5 @@ DIST gitlab-runner-15.3.0-deps.tar.xz 141251000 BLAKE2B e72c597a10e78f234f7879ff
DIST gitlab-runner-15.3.0.tar.gz 1306073 BLAKE2B cc7f1902e7cfc7577e936b411ae7f582c25757ed5d59cc5d61bb8f9c027ce292c7aac46788a44be78686f1705d5722373a9f5f2b295fd1eab2666e749fc50e06 SHA512 8eabe9a4fd04e46d4bf306dc202664e29f5cb12cba5d73820888957d694711702e026f79a84e1d5f5237cb3d1e7efed8e035129814dcc6354e708ee98e98cbe9
DIST gitlab-runner-15.3.1-deps.tar.xz 141247556 BLAKE2B 8ea8e519efabfe54ff2a70477e713285a80889e6f001adae7263626db4086112964dcde328662a96c3c92d251e294fed6cd8023772f74be650a63f7d7fd2bd58 SHA512 047b4b3ac5e4fb6d493b5ae51219bcd60b056265a146d4001299ccaee491e5b6b0da8a3f1f84d4d44ae0e726b732c69d59851735283c78ddd6456ab9a7a87d49
DIST gitlab-runner-15.3.1.tar.gz 1306831 BLAKE2B 032115edb7b0ae23d4f4083e542aa645e4f76fea04a63c5d3018080314081c82b2250d292b26b507101b627314d9142b0109f33fa8289a583010a5d692a6c1cd SHA512 62e543983e184c2e57189042f8281696e0428841890aef8779fce125041dbbd0626807491e5ae589e367f6b725fb93e663d94da3a051e2a9ec681b959c4bd85f
+DIST gitlab-runner-15.4.0-deps.tar.xz 141260140 BLAKE2B 876b71eb424bd5d65624718a666f7ff376b7d548056932e5f190974aa54bb7df5453b6fd6cb7a683a528035a8ddc0cec4a4a0f5481c491a6daac2e47edcba061 SHA512 1e940a8ac199b37d305d046f8f93d474e58881f76ee1e569d905cdc02f219dd5730ea7a4efc7ba297d5492996777daf2ec783788da9de6c5873528e0ed0d7c91
+DIST gitlab-runner-15.4.0.tar.gz 1309792 BLAKE2B 54b4c94a79c86097116aa1bd4fe9e70da648ec379de606f36a3abbd15b7e9a2e3fc2174d9c8190bfc4925fd9c2ff1658440760ce9360db1a24319c50f506973f SHA512 85d4efb63a6bad62b3ca0a5fae365a7bf33d14e94e9b0ee24b71a87983bef7c92f83ecce78918024aee1bc8375e1910b731238b5f3f5b77e798d34f08283dd63
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.4.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.4.0.ebuild
new file mode 100644
index 000000000000..07f23f03aeee
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.4.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=43b2dc3d
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}