summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Persson Forsberg <cat@catcream.org>2022-04-11 13:49:23 +0000
committerZac Medico <zmedico@gentoo.org>2022-04-11 12:18:58 -0700
commit43e759c25a8e2960d3dff78c6696cb257ebaa394 (patch)
treedf1370a9e132fffe6b2da3117da8bf07838cf09c /dev-util/flatpak-builder
parentnet-nds/tac_plus: use https (diff)
downloadgentoo-43e759c25a8e2960d3dff78c6696cb257ebaa394.tar.gz
gentoo-43e759c25a8e2960d3dff78c6696cb257ebaa394.tar.bz2
gentoo-43e759c25a8e2960d3dff78c6696cb257ebaa394.zip
dev-util/flatpak-builder: fixed building for musl
Closes: https://github.com/gentoo/gentoo/pull/24991 Closes: https://bugs.gentoo.org/834671 Signed-off-by: Alfred Persson Forsberg <cat@catcream.org> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-util/flatpak-builder')
-rw-r--r--dev-util/flatpak-builder/files/flatpak-builder-1.0.11-musl.patch18
-rw-r--r--dev-util/flatpak-builder/files/flatpak-builder-1.2.2-musl.patch55
-rw-r--r--dev-util/flatpak-builder/flatpak-builder-1.0.11.ebuild2
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-util/flatpak-builder/files/flatpak-builder-1.0.11-musl.patch b/dev-util/flatpak-builder/files/flatpak-builder-1.0.11-musl.patch
new file mode 100644
index 000000000000..b5ef0ec15504
--- /dev/null
+++ b/dev-util/flatpak-builder/files/flatpak-builder-1.0.11-musl.patch
@@ -0,0 +1,18 @@
+--- a/libglnx/glnx-macros.h
++++ b/libglnx/glnx-macros.h
+@@ -28,6 +28,16 @@
+
+ G_BEGIN_DECLS
+
++/* taken from glibc unistd.h and fixes musl */
++#ifndef TEMP_FAILURE_RETRY
++#define TEMP_FAILURE_RETRY(expression) \
++ (__extension__ \
++ ({ long int __result; \
++ do __result = (long int) (expression); \
++ while (__result == -1L && errno == EINTR); \
++ __result; }))
++#endif
++
+ /* All of these are for C only. */
+ #ifndef __GI_SCANNER__
diff --git a/dev-util/flatpak-builder/files/flatpak-builder-1.2.2-musl.patch b/dev-util/flatpak-builder/files/flatpak-builder-1.2.2-musl.patch
index db207e0e353c..626fbddd0352 100644
--- a/dev-util/flatpak-builder/files/flatpak-builder-1.2.2-musl.patch
+++ b/dev-util/flatpak-builder/files/flatpak-builder-1.2.2-musl.patch
@@ -1,9 +1,59 @@
+diff --git a/subprojects/debugedit/tools/debugedit.c b/subprojects/debugedit/tools/debugedit.c
+index 668777a..b3ba5cb 100644
+--- a/subprojects/debugedit/tools/debugedit.c
++++ b/subprojects/debugedit/tools/debugedit.c
+@@ -25,7 +25,11 @@
+ #include <byteswap.h>
+ #include <endian.h>
+ #include <errno.h>
++#ifdef __GLIBC__
+ #include <error.h>
++#else
++#include "error.h"
++#endif
+ #include <limits.h>
+ #include <string.h>
+ #include <stdlib.h>
+diff --git a/subprojects/debugedit/tools/error.h b/subprojects/debugedit/tools/error.h
+new file mode 100644
+index 0000000..c330dc3
+--- /dev/null
++++ b/subprojects/debugedit/tools/error.h
+@@ -0,0 +1,26 @@
++#ifndef _ERROR_H
++#define _ERROR_H
++#include <stdarg.h>
++#include <stdio.h>
++#include <stdlib.h>
++#include <string.h>
++#include <errno.h>
++
++static unsigned int error_message_count = 0;
++
++static inline void error(int status, int errnum, const char* format, ...)
++{
++ va_list ap;
++ fprintf(stderr, "%s: ", program_invocation_name);
++ va_start(ap, format);
++ vfprintf(stderr, format, ap);
++ va_end(ap);
++ if (errnum)
++ fprintf(stderr, ": %s", strerror(errnum));
++ fprintf(stderr, "\n");
++ error_message_count++;
++ if (status)
++ exit(status);
++}
++
++#endif
+diff --git a/subprojects/libglnx/glnx-macros.h b/subprojects/libglnx/glnx-macros.h
+index 6d8aca9..e3e4e33 100644
--- a/subprojects/libglnx/glnx-macros.h
+++ b/subprojects/libglnx/glnx-macros.h
@@ -28,6 +28,16 @@
-
+
G_BEGIN_DECLS
-
+
+/* taken from glibc unistd.h and fixes musl */
+#ifndef TEMP_FAILURE_RETRY
+#define TEMP_FAILURE_RETRY(expression) \
@@ -16,3 +66,4 @@
+
/* All of these are for C only. */
#ifndef __GI_SCANNER__
+
diff --git a/dev-util/flatpak-builder/flatpak-builder-1.0.11.ebuild b/dev-util/flatpak-builder/flatpak-builder-1.0.11.ebuild
index a8017f003f1d..20d616e0056d 100644
--- a/dev-util/flatpak-builder/flatpak-builder-1.0.11.ebuild
+++ b/dev-util/flatpak-builder/flatpak-builder-1.0.11.ebuild
@@ -33,6 +33,8 @@ BDEPEND="
)
"
+PATCHES=("${FILESDIR}/flatpak-builder-1.0.11-musl.patch")
+
src_configure() {
econf \
$(use_enable doc documentation) \